my dog learned polymorphism*
The moose likes JSP and the fly likes Jsp 1.0 problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Jsp 1.0 problem " Watch "Jsp 1.0 problem " New topic
Author

Jsp 1.0 problem

nirail rail
Ranch Hand

Joined: Nov 14, 2003
Posts: 39
i am working on websphere 3.5 Ibm http server on nt -------- jsp1.0

i am not getting result when using <jsp:include>
______________________________________________________________
<jsp:include page="http://localhost/search/bin/productSearch.jsp?q=<%=q%>" flush="false" />
i get error invalis include tag
--------------------------------------------------------

___________________________________________________________________
when i use
<jsp:include page="http://localhost/search/bin/productSearch.jsp?q=<%=q%>" flush="true" />
no error is displayed page before this line is displayed and then it blank page with no error
-------------------------------------------------------------------


pls help
Sri Gnana
Ranch Hand

Joined: Apr 29, 2004
Posts: 166
Hi
I think it will help you

JSP Syntax
<jsp:include page="{relativeURL | <%= expression %>}"
flush="true| false" />

or

<jsp:include page="{relativeURL | <%= expression %>}"
flush="true| false" >
<jsp aram name="parameterName"
value="{parameterValue | <%= expression %>}" />+
</jsp:include>

----------
This example determines the file to include from a request parameter:
<jsp:include page='<%= request.getParameter("incFile") %>' />

-----------

<jsp: include page="order.jsp" flush="true">
<jsp aram name="currency" value="<%=request.getParameter(\"money\")%>"/>
<jsp aram name="amount" value="<%=request.getParameter(\"number\")%>"/>
</jsp:include>

[ July 15, 2004: Message edited by: Sri Gnana ]
[ July 15, 2004: Message edited by: Sri Gnana ]

Thanks & Regards
Sri Gnana
Everythings Programmed!...
Jeroen Wenting
Ranch Hand

Joined: Oct 12, 2000
Posts: 5093
flush="false" is not supported by your server.


42
Sri Gnana
Ranch Hand

Joined: Apr 29, 2004
Posts: 166
Using flush=true also showing the blank page.
i think problem is bcoz of q=<%=q%>
nirail rail
Ranch Hand

Joined: Nov 14, 2003
Posts: 39
HI
Sri Gnana & jeroen,

I was able to solve problem bcoz of u r promt reply
it was due to ?q=<%=q%>,

it is totally not necessary as i have included those pages it get the parameter in included pages

thanx a lot

Reagrds
Nirail
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Jsp 1.0 problem
 
Similar Threads
jsp:include tag not processed in Tomcat 4.0.4 and Apache2 combination
Handling Error in JSP
Problem with forward and include JSP tag
jsp:include in error page does not work
WebSphere JSP