This week's book giveaway is in the Mac OS forum.
We're giving away four copies of a choice of "Take Control of Upgrading to Yosemite" or "Take Control of Automating Your Mac" and have Joe Kissell on-line!
See this thread for details.
The moose likes JSP and the fly likes When I type Russian in my .jsps, it displays it as a bunch of squares! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » JSP
Bookmark "When I type Russian in my .jsps, it displays it as a bunch of squares!" Watch "When I type Russian in my .jsps, it displays it as a bunch of squares!" New topic
Author

When I type Russian in my .jsps, it displays it as a bunch of squares!

Ivan Jouikov
Ranch Hand

Joined: Jul 22, 2003
Posts: 269
Hi everyone!



First of all, in my JSP page I specify:

<%@ page language="java" contentType="text/html; charset=UTF-8" %>

<%@ page pageEncoding="UTF-8"%>



Now, in my <HEAD> I have:

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">

And when I type the following in my page:

This is text in English

����� �� ������

The English text displays just fine, whereas the Russian is a bunch of squares. What could be the problem? Is it possible that the way I SAVE the page could affect it? I am using Eclipse with Lomboz, and it has no option to change encoding of the file. Lemme try Microsoft word..

Nope, Microsoft word doesn�t have an option to save page in different encoding.

I have no clue what to do, and this is urgent because this project is due tomorrow, can someone PLEASE help with this?

By the way, My browser is configured properly � I have no problem displaying Russian stuff on other web sites. Goddamn tomcat L((((((
[ July 19, 2004: Message edited by: Bear Bibeault ]
 
GeeCON Prague 2014
 
subject: When I type Russian in my .jsps, it displays it as a bunch of squares!