• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Fixing gremlin URL bug

 
Maximilian Xavier Stocker
Ranch Hand
Posts: 381
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
jdbc dbc

 
Maximilian Xavier Stocker
Ranch Hand
Posts: 381
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As you can see both in code tags and outside jdbc : odbc or jdbc : oracle (without the spaces in both cases) gets eaten by the emote/gremlin tag.

This makes alot of posts really hard to read in the JDBC forum as well as copy and paste to see if code compiles/generall works. My suggestions would be

- fix the regex so it only looks for : o surrounded by whitespace
- fix the parsing/regex so that it doesn't do anything to stuff in a code block
- change the text to type for the embarrassed emote
[ February 05, 2006: Message edited by: Maximilian Stocker ]
 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Or just check the checkbox for "Disbale smilies in this post." before you submit. ;)
[ February 05, 2006: Message edited by: Gregg Bolinger ]
 
Maximilian Xavier Stocker
Ranch Hand
Posts: 381
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Gregg Bolinger:
Or just check the checkbox for "Disbale smilies in this post." before you submit.

[ February 05, 2006: Message edited by: Gregg Bolinger ]


Lovely idea. Except that it is in reading posts by others that I am having this problem.

I will see if I can find the source for this and submit a fix. The whitespace around the tag would be the easiest to do and would work without problems.
 
Jim Yingst
Wanderer
Sheriff
Posts: 18671
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There are other bugs as well where constructs in code can set off various UBB "features". E.g. accessing an array as "arr[ i ]" is fine, but if you omit the spaces UBB sees an italics tag. Or "for( ; ; )" becomes "for (; ". I think the preferred general solution would be to turn off all other special character parsing inside code tags. Though this may be difficult to isolate; the UBB tag parsing code was particularly messy as I recall.

Max, I'll send you an e-mail.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic