File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSP and the fly likes Javabean in JSP impossible Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "Javabean in JSP impossible" Watch "Javabean in JSP impossible" New topic
Author

Javabean in JSP impossible

dav mal
Greenhorn

Joined: Nov 30, 2004
Posts: 2
Hi!
I have been trying for two days to start using javabeans with jsp but I can�t get my jsp-file to use a bean that I have created. I save the .jsp file in:
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\ROOT\kise

And the javabean is saved in:
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\ROOT\WEB-INF\classes\Beans

The code for the bean is:


the code for the jsp-page is:


I get the internal error message:


Does anyone have a clue what to do, it feels like I have tried everything? /davmal
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61218
    
  66



Are you putting the .java or the .class file in this location?


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
dav mal
Greenhorn

Joined: Nov 30, 2004
Posts: 2
I have the .class file in that directory. /davmal
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12785
    
    5
My wild guess is that it does not like the fact that you have named the class with a lower case initial letter (and the package with upper case) - contrary to the Java convention.
If this is not the answer, the next thing to do is to search the Tomcat source code for the point where that exception is generated.
Bill
Logan Owen
Greenhorn

Joined: Dec 01, 2004
Posts: 24
What version of Tomcat are you using? Because I had this same problem when I moved to Tomcat 5. I do not remember the exact fix, but it had something to do with the useBean tag. I was using class="package.class" and in T5, it has to use type="package.class" or vice versa to instantiate the bean. You might want to do some checking and see if that fixes your problem. After instantiating it, the code as was worked fine on all other pages, it was just the 1st page that was creating the bean that had problems.

Edit: Duh...obviously you are using Tomcat 5...oh well.
[ December 01, 2004: Message edited by: Logan Owen ]
Elizabeth Kominowski
Greenhorn

Joined: Dec 01, 2004
Posts: 1
<%-- <jsp:useBean id="beanInstanceName" scope="session" class="beanPackage.BeanClassName" /> --%>


X
Logan Owen
Greenhorn

Joined: Dec 01, 2004
Posts: 24
OK...here is what I was talking about. I was having this exact problem, and doing what was suggested in this thread about the class and type fixed my problem. Maybe it can help you.

linky
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Javabean in JSP impossible