*
The moose likes JSP and the fly likes Custom Tags Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Custom Tags" Watch "Custom Tags" New topic
Author

Custom Tags

paromitabanerjee mukerjibanerjee
Greenhorn

Joined: Dec 20, 2004
Posts: 23
Hi,
Am stuck with Tag Libraries. the engine shows me 'not found' error. I havs follwed the following steps :

1) I hav created a SimpleTag.class and stored it in /webapps/root/egPM/WEB-INF/classes/.
2) Have created a TLD and stored it in /webapps/root/egPM/WEB-INF/.
The code in the TLD is :

<?xml version="1.0" encoding="ISO-8859-1" ?>
<!DOCTYPE taglib PUBLIC "-//Sun Microsystems, Inc.//DTD JSP Tag Library 1.1//EN" "http://java.sun.com/j2ee/dtds/web-jsptaglibrary_1_1.dtd">

<taglib>
<tlibversion>1.0</tlibversion>
<jspversion>1.1</jspversion>
<shortname>MyFirstTag</shortname>
<info>My tag library descriptor file</info>

<tag>
<name>SimpleTag</name>
<tagclass>SimpleTag</tagclass>
</tag>
</taglib>

3) in the /webapps/root/egPM/WEB-INF/web.xml file I hav added the following code :

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>
<display-name>Welcome to Tomcat</display-name>
<description>
Welcome to Tomcat
</description>
<taglib>
<taglib-uri>/myTLD</taglib-uri>
<taglib-location>/WEB-INF/taglib.tld</taglib-location>
</taglib>
</web-app>

4) I hav created a simple jsp file to access the tags and hav placed it at :
/webapps/egPM/AccessingCustomTags.jsp

The code is as follows :
<html>
<head><title>Displaying a CustomTag</title></head>
<body>
<%@ taglib uri="/myTLD" prefix="myTags" %>

<myTags:SimpleTag></myTags:SimpleTag>
</body>
</html>



But when i run this file, an error is displayed saying /myTLD doesnt exist. I hav checked with a couple of books and followed exactly as they hav mentioned but to no avail. the error persists.....

Thnkz in advance for the help.

Paromita.
SCJP.
 
Don't get me started about those stupid light bulbs.
 
subject: Custom Tags
 
Similar Threads
Custom Tag NOT Compiling
CUSTOM TAG NOT WORKING
Problem with Custom Tags
Internal Servlet Error with Custom tag
Element type "tlibversion" must be declared