• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Just new in crystal report XI

 
Smith Magadia
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm just new in Crystal Report XI and unfortunately haven't successfully run it in our struts webapp project. I'm having this kind of error, I hope some would know how to solve it. I've been searching the said package/class but to no avail.

java.lang.NoClassDefFoundError: com/crystaldecisions/reports/common/be
java.lang.ClassLoader.defineClass1(Native Method)
java.lang.ClassLoader.defineClass(ClassLoader.java:620)
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:1634)
org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:860)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1307)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1189)
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
com.crystaldecisions.reports.reportengineinterface.JPEReportSourceFactory.createReportSource(Unknown Source)
org.apache.jsp.motivareport1_jsp._jspService(motivareport1_jsp.java:75)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:137)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:210)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:295)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1063)
org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:263)
org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:239)
org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:302)
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:229)
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1194)
org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64620
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looks like the crystal reports classes are not available. Does it come with a jar file? Where did you put said jar file?
 
Smith Magadia
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i guess it was just mess up, so what i did was copy & follow the the sample webapp of crystal report, which is already included, and fortunately, its now workn. anywayz a million thanks for your time Bear!
 
Andrew Schwantes
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am receiving this same error but cannot resolve the issue. All the jar files are located in my WEB-INF/lib folder of my WAR, as well as copied into the Java/lib folder on the server. Like the above user did, I followed exactly what the BusinessObjects tutorials say, step for step. Everything is in the correct locations according to that documentation yet I receive this NoClass error. If there is anyone that can be of help I'll be happy to post more info as needed. Thanks.
 
sag mam
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I'm having the same prob. How did you solve this eventually?
thanks.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic