• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Environmental setup Issue-EL

 
Parameswaran Thangavel
Ranch Hand
Posts: 485
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi
Currently i am using Tomcat 4.0.

To run JSTL1.1 and EL, one should have Tomcat5.x, so i tried to install it and run my program.
but i got the error saying "This version of Apache Tomcat will run in J2SE 5.0" is that mean tom5.x, excepting higher version of JRE, if so what should be the version and from where i can download it.

Thanx
 
Vishnu Prakash
Ranch Hand
Posts: 1026
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

is that mean tom5.x, excepting higher version of JRE, if so what should be the version and from where i can download it.


You need java 5.X version. You can download it from Sun site.
 
Adeel Ansari
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Not Tomcat 5.x, it must be Tomcat 5.5.x
[ April 27, 2006: Message edited by: Adeel Ansari ]
 
Stefan Evans
Bartender
Posts: 1692
10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just to make things absolutely clear.
Tomcat 5 is a JSP2.0 container (and as such uses JSTL1.1)
There are two flavours of Tomcat5

Tomcat 5.0.x - Can run on Java 1.4
Tomcat 5.5.x - Requires J2SE 5.0 (or Java 1.5 if you prefer) to run.

You have obviously downloaded Tomcat5.5, and as such also need to upgrade to the latest version of Java if you want to use it.

Cheers,
evnafets
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64724
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is a compatibility package that will allow Tomcat 5.5 to run with JDK 1.4, but I'd recommend biting the bullet and upgrading to JDK 1.5.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic