Meaningless Drivel is fun!*
The moose likes JSP and the fly likes JSTL Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "JSTL Problem" Watch "JSTL Problem" New topic
Author

JSTL Problem

Unnsse Khan
Ranch Hand

Joined: Nov 12, 2001
Posts: 511
Hello again,

I am using MyEclipse (JDK 1.5 & Tomcat 5.5.9), JSTL 1.1, and created a EditProduct.jsp file, such as follows:



When I point my browser to http://localhost:8080/webshop/EditProduct.jsp

I receive this error message inside the browser:



Does anyone know what I might be possibly missing?

Am stumped because MyEclipse usually handles everything (enabling JSTL 1.1), very smoothly, and deployment becomes straightforward.

Any help, hints, and suggestions would be most appreciated!

Sincerely,
Balasubramani Dharmalingam
Ranch Hand

Joined: Dec 06, 2004
Posts: 116
Put jstl.jar and standard.jar in your application's lib directory.


Balasubramani SD,<br />SCJP 1.4,SCWCD 1.4,SCJP 5.0<br /><a href="http://sd.balasubramani.googlepages.com" target="_blank" rel="nofollow">www.sd.balasubramani.googlepages.com</a>
Unnsse Khan
Ranch Hand

Joined: Nov 12, 2001
Posts: 511
Thanks for the response!

Actually, MyEclipse does that for you.

After the first post, I deleted the directory under /webapps/webshop and
then restarted MyEclipse. I chose the hot deploy (expanded) and it worked.
 
jQuery in Action, 2nd edition
 
subject: JSTL Problem