wood burning stoves 2.0*
The moose likes JSP and the fly likes Old Version Of JSP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "Old Version Of JSP" Watch "Old Version Of JSP" New topic
Author

Old Version Of JSP

James Ellis
Ranch Hand

Joined: Oct 14, 2004
Posts: 205
I am using an older than dirt version of WebSphere which must have JSP 1.1 installed, because it doesn't support the EL function fn:indexOf, as in



I can't deploy any new libraries (no permissions). Does JSTL 1.0 offer any other way of parsing a string and searching for certain characters or am I upd the creek?

Thanks,
Jim

Specs:
WebSphere Commerce Version 5.6
JSP Version: ? Probably 1.1
JSTL Version: ? Probably 1.0

[ March 14, 2007: Message edited by: James Ellis ]
[ March 14, 2007: Message edited by: James Ellis ]
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61095
    
  66

I believe JSTL 1.0 requires JSP 1.2, so that may be what you are running.

And correct, JSTL 1.1 on JSP 2.0 is necessary to use the fn library.

You'll probably need to resort to scriptlets, or better yet, factor all processing out into the servlet controller and pass the results to the JSP.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Old Version Of JSP