This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JSP and the fly likes JSTL Configuration (was: tomcat installation) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "JSTL Configuration (was: tomcat installation)" Watch "JSTL Configuration (was: tomcat installation)" New topic
Author

JSTL Configuration (was: tomcat installation)

Ra Carter
Ranch Hand

Joined: Jul 30, 2005
Posts: 96
i am using tomcat on ubuntu linux but i can't get it started.

at some point in time i did:
$ sudo apt-get install sun-java5-jdk

then
$ sudo apt-get install tomcat5.5

then because tomcat told me to when i tried to start it, i updated /etc/default/tomcat5.5 with JAVA_HOME=/usr/bin
($ which java gives me /usr/bin/java by the way)

finally I go:
$ sudo /etc/init.d/tomcat5.5 start
Starting Tomcat 5 servlet engine using Java from /usr/bin: tomcat5.5.

BUT i dont get any webpage when i navigate to http://localhost:8080

i turned off any firewall settings just in case. i dont even know where to start troubleshooting now. any suggestions?
[ March 26, 2007: Message edited by: Ben Souther ]
Ra Carter
Ranch Hand

Joined: Jul 30, 2005
Posts: 96
after some more investigations i found that the tomcat service probably never started successfully and i also found the log files for tomcat which said:
Using CATALINA_BASE: /var/lib/tomcat5.5
Using CATALINA_HOME: /usr/share/tomcat5.5
Using CATALINA_TMPDIR: /var/lib/tomcat5.5/temp
Using JRE_HOME: /usr/bin
Using Security Manager
/usr/share/tomcat5.5/bin/catalina.sh: 323: /usr/bin/bin/java: not found


so I updated the JAVA_HOME entry in /etc/default/tomcat5.5 to say JAVA_HOME=/usr

the last entry in the log files seem to indicate that tomcat started?
INFO: Server startup in 11404 ms


but still nothing on http://localhost:8080 or http:/localhost:80
Ra Carter
Ranch Hand

Joined: Jul 30, 2005
Posts: 96
uh.. for closure i guess..

i found out that the port is specified in /var/lib/tomcat5.5/conf/server.xml and that it was 8180 by default on my installation. tomcat worked when i went to http://localhost:8180

but the next problem i have is when I try to execute the JSP examples, I get this error:

[ March 25, 2007: Message edited by: Ra Carter ]
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Glad your other problem is solved.

This is now an actual JSP problem so I'm going to move it back to the JSP forum.

There is a lot of information in the JSP FAQ for helping to insure that you've got the proper JSTL libraries for the version of the container you're using, as well as making sure your declarations are right. Take a look there and make sure you've got every thing right.


Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
 
 
subject: JSTL Configuration (was: tomcat installation)
 
Similar Threads
Start Tomcat 7 as tomcat user (not root user)
Installing Tomcat 5.5 in Suse Linux
tomcat and java_home
How to install tomcat5 in Ubuntu 11.04 when it is not in the apt-cache?
Deploying a Visual Web Pack Application from Netbeans 5.5.1 to Tomcat 5.5