Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

web.xml

 
bnkiran kumar
Ranch Hand
Posts: 176
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
in DD, i made following entry after <welcome-file-list> entry ,
<error-page>
<error-code>404</error-code>
<location>/Notfound.html</location>
</error-page>

In Notfound.html,
i made following enty,
<%@page isErrorPage="true" %>

when i am trying an Url which does not exist, Notfound.html is not getting called instead container is throwing its default error page...
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you're using IE, make sure that "display friendly errors" is turned off in the options (I can't recall the exact name of the option)
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by bnkiran kumar:


In Notfound.html,
i made following enty,
<%@page isErrorPage="true" %>


If you want your JSP directives to actually do something, you need to change the file extension from ".html" to ".jsp".
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Where did you put your Notfound.html page?
Make sure it's in the root of the web application.

Also check the spelling.
Make sure the casing is exactly the same in the deployment descriptor as it is in the actual file name.
 
bnkiran kumar
Ranch Hand
Posts: 176
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Satou and Ben,i will check...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic