File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes IDEs, Version Control and other tools and the fly likes JSP deployment Error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Make it so: Java DB Connections & Transactions this week in the JDBC forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "JSP deployment Error" Watch "JSP deployment Error" New topic

JSP deployment Error

Tom Anderson

Joined: Jan 06, 2008
Posts: 1
Hi everyone,
i need a serious help. i have been trying out this thing for a week and i still cant solve the issue.

I am using Netbeans 6 with bundled tomcat 6.0.14
OS: Windows Vista Home Premium 32 bit
Memory: 2 GB
Processor: AMD Turion 64 TL-58

i created a web application project using netbeans and tried to deploy it by running the project

and i saw following things in the console:

Created dir: F:\test\build\web\WEB-INF\classes
Created dir: F:\test\build\web\META-INF
Copying 1 file to F:\test\build\web\META-INF
Copying 3 files to F:\test\build\web
Starting Tomcat process...
Waiting for Tomcat...
Starting of Tomcat failed.
Deployment error:
Starting of Tomcat failed.
See the server log for details.
at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy

at org.netbeans.modules.j2ee.ant.Deploy.execute(
at sun.reflect.GeneratedMethodAccessor97.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke

at java.lang.reflect.Method.invoke(
Caused by: org.netbeans.modules.j2ee.deployment.impl.ServerException: Starting of Tomcat

at org.netbeans.modules.j2ee.deployment.impl.ServerInstance._start

at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget

at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget

at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.start

at org.netbeans.modules.j2ee.deployment.impl.TargetServer.startTargets

at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy

... 16 more
BUILD FAILED (total time: 3 minutes 3 seconds)

again i saw the tomcat console:

Using CATALINA_BASE: C:\Users\.netbeans\6.0\apache-tomcat-6.0.14_base
Using CATALINA_HOME: C:\Program Files\Apache Software Foundation\Apache Tomcat 6.0.14
Using CATALINA_TMPDIR: C:\Users\.netbeans\6.0\apache-tomcat-6.0.14_base\temp
Using JRE_HOME: C:\Program Files\Java\jdk1.6.0_03
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.AprLifecycleListener init
Jan 6, 2008 4:55:55 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8084
Jan 6, 2008 4:55:55 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1410 ms
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.14
Jan 6, 2008 4:55:56 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8084
Jan 6, 2008 4:55:56 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /
Jan 6, 2008 4:55:57 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/63 config=null
Jan 6, 2008 4:55:57 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1371 ms

I opened the browser and tried localhost:8084 and it shows tomcat startup page (tomcat has already started and its working). but why does netbeans 6 always report that tomcat failed to start.

please somebody help me. i am new to jsp and servlets and trying to study it. but since last week i could not make any progress. I am using netbeans 6 with bundled tomcat 6.0.14.

Thanks in advance.
[ January 06, 2008: Message edited by: Bear Bibeault ]
Bear Bibeault
Author and ninkuma

Joined: Jan 10, 2002
Posts: 63548

"khaik khaik", please check your private messages.

[Asking smart questions] [About Bear] [Books by Bear]
pratik suthar

Joined: Dec 28, 2009
Posts: 1
I am also getting same error please help me in the same
I agree. Here's the link:
subject: JSP deployment Error
It's not a secret anymore!