Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JSTL does not show values

 
Bobby Sharma
Ranch Hand
Posts: 598
3
Google App Engine jQuery Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat 6
java 6
Eclipse IDE for j2ee 3.x
-----------------------------


it shows following output:
Movie list:
$(movieList)
but I want values of string array.

I put jslt 1.1 taglibs on web-inf/classes,web-inf/lib and also included
as an external jar on my web-app.
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
  • If you are using servlets 2.4+, you don't need to set isELIgnored. It's false by default
  • EL is identified using curly brackets : $(movieList) -> ${movieList}
  • You don't need to put anything in WEB-INF/classes. JSTL1.1 (standard.jar and jstl.jar) in WEB-INF/lib is enough


  • [ March 27, 2008: Message edited by: Christophe Verre ]
     
    Bobby Sharma
    Ranch Hand
    Posts: 598
    3
    Google App Engine jQuery Windows
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Problem solved.

    brackets problem LOL
    ----------------------
    Sir I put jslt 1.1 almost everywhere on my eclipse web-app without success.
    one more thing jstl 1.1 came with tons of tld files along with stantard.jar and jstl.jar files,I already took care of jars but where to put those tld file I have no idea.
    [ March 27, 2008: Message edited by: omi sharma ]
     
    Christophe Verré
    Sheriff
    Posts: 14691
    16
    Eclipse IDE Ubuntu VI Editor
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Please follow all instructions on this page. And please remove those TLD files You don't need them.
     
    Bobby Sharma
    Ranch Hand
    Posts: 598
    3
    Google App Engine jQuery Windows
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    thank you sir , problem solved.
    I did set this () and I should have set {}. LOL

    thanks for your help
     
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic