This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Need help for Displaying in jsp

 
Philip Zac
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all Appfusers,

I am practically a newbie in this field.

I just got an error given below:

Error:




Using log.debug, I got this




I am using customized User and Role classes.

Here is my daoHibernate:






And my jsp page







I hope I have made my errors clear to you. I hope someone will help me .

Cheers,
PHilip
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It looks like you're trying to read a property named "username" from an object or map that doesn't have a username field.
 
Philip Zac
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Ben,

Thanks for the reply. But I think I did everything going correctly. Because I use the User class with the attributes username. see below:



I hope I am correct....

Thanks,
Philip
 
Philip Zac
Ranch Hand
Posts: 66
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got the problem solved.....whewwwwwwwwwwwwwwwwwww!!!


Here is my OLD daoHibernate:


---------------------------

Here is my New daoHibernate:



-----------------------------

and the Named Query just above the User class is given below :---


------------

Anyway, Thanks Ben for pointing the error. I guess my SQL query is not good when using createQuery. It is easier to check out the query using MySQL and then put it in the name query......

Well Thanks once again,

your little Greenhorn.
Philip
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic