File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSP and the fly likes JSTL :  not working with JSP 2.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "JSTL :  not working with JSP 2.0" Watch "JSTL :  not working with JSP 2.0" New topic
Author

JSTL : not working with JSP 2.0

chandra konduru
Greenhorn

Joined: Jun 26, 2008
Posts: 3
Hi
I was trying to run JSP 2.0 tag sample. here are the tag and jsp files.

wrapper.tag
----------
<%@ tag body-content="scriptless" %>
<%@ attribute name="a" required="true" %>
<%@ attribute name="b" required="true" %>
<%@ attribute name="c" required="true" %>
<%@ attribute name="d" required="false" %>
<p> Header
<p> Attributes - ${a}, ${b}, ${c}</p>
<table>
<tr>
<td>${a}</td>
<td>${b}</td>
</tr>
</table>
<p> Footer
---------- and my JSP is
main.jsp
------------
<%@ page contentType="text/html;charset=UTF-8" language="java" %>
<%@ taglib prefix="tags" tagdir="/WEB-INF/tags" %>
<%@ taglib uri="http://java.sun.com/jstl/core" prefix="c" %>

<tags:wrapper a="1" b="2" c="3" >
<p> Wrapped Content
</p>
</tags:wrapper>

----
web.xml contents
<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_3.xsd"
version="2.3">


when I ran main.jsp I am getting
Attributes - ${a}, ${b}, ${c}
instead of Attributes - 1,2,3

the values are not being evaluated. Any suggestion/help would be appreciated. I used version 2.4 also. but i am getting this error
"According to TLD or attribute directive in tag file, attribute value does not accept any expressions" when using 2.4.

Any idea??
Thanks
-Chandra K
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61764
    
  67

I'm confused. What does this have to do with the JSTL?

And, please be sure to use UBB code tags when posting code to the forums. Unformatted code is extermely hard to read and many people that might be able to help you will just move along. Please read this for more information.

You can go back and change your post to add code tags by clicking the .


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61764
    
  67

Your issue is that your web app is incorrectly declared as a servlets 2.3 web app. See the JSP FAQ to see how to correctly declare your web app as Servlets 2.4 (which enables the EL).
chandra konduru
Greenhorn

Joined: Jun 26, 2008
Posts: 3
Thanks guys. it worked. There is a problem with web-app format. yes it has nothing to do with JSTL.my bad. anyway thanks once again for your advice.
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

You know that custom tags that write yourself are not the same thing as JSTL, right?


Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSTL : not working with JSP 2.0