aspose file tools
The moose likes JDBC and Relational Databases and the fly likes Error while using jdbc2.0 features with SqlServer Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Groovy Fundamentals video training course this week in the Groovy forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "Error while using jdbc2.0 features with SqlServer" Watch "Error while using jdbc2.0 features with SqlServer" New topic
Author

Error while using jdbc2.0 features with SqlServer

nandinivn
Greenhorn

Joined: Jun 25, 2001
Posts: 1
Hi all,
I encountered an error while executig my application with SQLServer ,Cud anyone
Iam using Jdbc2.0 still getting the foll problem
find a soln for this :-
Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
Connection con = DriverManager.getConnection("jdbc dbc:test","sa","");
Statement stmt = con.createStatement(ResultSet.TYPE_SCROLL_INSENSITIVE,ResultSet.CONCUR_UPDATABLE);
ResultSet res = stmt.executeQuery("select * from emp");
When I use ResultSet.TYPE_SCROLL_SENSITIVE in con.createStatement
it works but when i use the above type as mentioned iam getting the foll..error
java.sql.SQLException: [Microsoft][ODBC SQL Server Driver]Optional feature not implemented

Thanx in advance
nandini&Hema
[This message has been edited by nandinivn (edited June 25, 2001).]
rani bedi
Ranch Hand

Joined: Feb 06, 2001
Posts: 358
Which JDBC are you using? I think you should get JDBC 2.0.
One of the new features in the JDBC 2.0 API is the ability to move a result set's cursor backward as well as forward.


Cheers,<br />Rani<br />SCJP, SCWCD, SCBCD
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error while using jdbc2.0 features with SqlServer