aspose file tools*
The moose likes JDBC and the fly likes Problems setting drivers Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "Problems setting drivers" Watch "Problems setting drivers" New topic
Author

Problems setting drivers

jason adam
Chicken Farmer ()
Ranch Hand

Joined: May 08, 2001
Posts: 1932
I have the following code in a class, which has objects of it created by two applets.

I get the JOptionPane showing the message "Getting Drivers" twice, and then the applet fails to initialize. It apparently is getting hung up on Class.forName(...).newInstance(). I can run any a test servlet that gets a JDBC connection just fine. It doesn't appear to be a path problem, because it compiles fine.
Any ideas on where I should start looking?
Thanks!
Jason
jason adam
Chicken Farmer ()
Ranch Hand

Joined: May 08, 2001
Posts: 1932
Well, I got it to work, but I had to copy the folder that contained all the classes for the drivers to the location that my applets were in. Shouldn't have to do this, should I?
Jamie Robertson
Ranch Hand

Joined: Jul 09, 2001
Posts: 1879

Originally posted by jason adam:
Well, I got it to work, but I had to copy the folder that contained all the classes for the drivers to the location that my applets were in. Shouldn't have to do this, should I?

did you put the jdbc driver file into your classpath?
Jamie
jason adam
Chicken Farmer ()
Ranch Hand

Joined: May 08, 2001
Posts: 1932
Yup, it's in there. Just seems like anytime I want to use the drivers, I have to have the zip, jar, or extracted package in the same location that the application is in.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems setting drivers