aspose file tools*
The moose likes JDBC and the fly likes JDBC Problem.... Why no Answer Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "JDBC Problem.... Why no Answer" Watch "JDBC Problem.... Why no Answer" New topic
Author

JDBC Problem.... Why no Answer

suresh subramanian
Greenhorn

Joined: Jan 02, 2002
Posts: 1
Hi All
I am using Lotus Domino 5.0 and Lotus Domino JDBC Driver 1.1. When I run my applet in JView (MS Applet viewer)I don't have any problem. But When I tried in appletviewer, I am getting the following error.
Error Occured:Unable to load native library: access denied (java.lang.RuntimePer
mission loadLibrary.)
java.sql.SQLException: Unable to load native library: access denied (java.lang.R
untimePermission loadLibrary.)
at lotus.jdbc.domino.DominoEnvCLI.<init>(DominoEnvCLI.java)
at lotus.jdbc.domino.DominoDriver.<init>(DominoDriver.java)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
orAccessorImpl.java:42)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
onstructorAccessorImpl.java:30)
at java.lang.reflect.Constructor.newInstance(Constructor.java:277)
at java.lang.Class.newInstance0(Class.java:301)
at java.lang.Class.newInstance(Class.java:254)
at sTest.fnGetNotesServer(sTest.java:39)
at sTest.init(sTest.java:16)
at sun.applet.AppletPanel.run(AppletPanel.java:344)
at java.lang.Thread.run(Thread.java:539)
***************************************
My Code is
import java.sql.*;
import java.util.*;
import java.applet.Applet;
import java.lang.*;
import java.awt.*;
import javax.swing.JApplet;
import lotus.jdbc.domino.*;
public class sTest extends Applet
{
protected String strMessage = new String("Initializing");
public void init()
{
strMessage = "Initializing";
fnGetNotesServer();
}
public void paint(Graphics g)
{
g.drawString(strMessage, 10, 30);
}
public void fnGetNotesServer()
{
java.sql.Connection con;
java.sql.DriverPropertyInfo[] outprops;
java.util.Properties inProps;
java.sql.Driver drv;
String strServerName = new String("local");
String strConnectionString = new String("jdbc omino:/Test.nsf/Sapphire/Personal");
Properties connProp = new Properties();
connProp = null;
try
{
try
{
drv = (Driver) Class.forName("lotus.jdbc.domino.DominoDriver").newInstance();
con = DriverManager.getConnection(strConnectionString);
if(con != null)
{
strMessage = "Connection Success";
repaint();
}
else
{
strMessage = "Connection Failure";
repaint();
}
}
catch(ClassNotFoundException e)
{
System.out.println("Error Occured:" + e.getMessage());
e.printStackTrace();
}
}
catch(Exception e)
{
System.out.println("Error Occured:" + e.getMessage());
e.printStackTrace();
}
}
}
*****************************************
The applet is signed.
Thanks in advance
Thanks & Regards
Suresh Subramanian
***************************************
[ January 03, 2002: Message edited by: suresh subramanian ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JDBC Problem.... Why no Answer
 
Similar Threads
VAJ & lotus jdbc domino database access problem
VAJ & lotus jdbc domino database access problem
Error when not in Main()
Unable to load Lotus notes JDBC Driver
iSeries V5R2-Native DB2 access in QShell-ClassNotFoundException