File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JDBC and Relational Databases and the fly likes Another JDBC:Oracle problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "Another JDBC:Oracle problem" Watch "Another JDBC:Oracle problem" New topic

Another JDBC:Oracle problem


Joined: Jan 04, 2002
Posts: 2
I have probrably read every single post regarding this issue. I've followed every single suggestion but it still doesnt work for me. Can someone please help me figure out why I keep getting the error message:
Exception in thread "main" java.lang.NoClassDefFoundError: MakingTheConnection
When I run javac it compiles it without a problem. As soon as I type java MakingTheConnection then the exception error pops up. Here is the code:
import java.sql.*;
public class MakingTheConnection {
public static void main(String[] args) {

try {

Connection databaseConnection =
DriverManager.getConnection("jdbc racle:thin:@maxcorp1:1524:maxdb", "SYS", "password");

System.out.println("Connection established successfully!");

catch (ClassNotFoundException cnfe) {
catch (SQLException sqle) {
I'm running it on a Windows XP machine. I configured the classpath and path properly but now i'm all out of ideas. PLEASE HELP OUT A GREENHORN........

Joined: Jan 04, 2002
Posts: 2
Nevermind... I solved the problem.
David O'Meara

Joined: Mar 06, 2001
Posts: 13459

The Java Ranch has thousands of visitors every week, many with surprisingly similar names. To avoid confusion we have a naming convention, described at .
We require names to have at least two words, separated by a space, and strongly recommend that you use your full real name. Please re-register and select a new name which meets the requirements.
I agree. Here's the link:
subject: Another JDBC:Oracle problem
It's not a secret anymore!