aspose file tools*
The moose likes JDBC and the fly likes CachedRowSet is an abstract class Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Databases » JDBC
Bookmark "CachedRowSet is an abstract class" Watch "CachedRowSet is an abstract class" New topic
Author

CachedRowSet is an abstract class

Francois Bourgault
Ranch Hand

Joined: Oct 30, 2001
Posts: 67
Hi all,
This afternoon I was using the CacheRowSet() and it was working just fine. Now for the last 1/2 hour I get the following error;
Generated servlet error:
C:\Apache\jakarta-tomcat\work\localhost\myServlets\Src\calendar_0005fwk_0005fmt_0005fsummary$jsp.java:174: class sun.jdbc.rowset.CachedRowSet is an abstract class. It can't be instantiated.
CachedRowSet aResultSet = new CachedRowSet();
Nothing has changed in my setup. I added the rowset.jar in the classpath and it used to work. Any idea what may caused the above error?
Thanks,
Francois.
Francois Bourgault
Ranch Hand

Joined: Oct 30, 2001
Posts: 67
It works now. I was trying to do something like this:
ResultSet rs = stmt.executeQuery("SELECT * FROM EMPLOYEES");
CachedRowSet crs = new CachedRowSet();
crs.populate(rs);
this is taken from Sun's documentation - CachedRowSet. Oh Well!!!
Thanks
Francois
Stanley Tan
Ranch Hand

Joined: May 17, 2001
Posts: 243
Well, it's in the documentation because it works that way too. Funny, cuz I used that code before and it worked for me.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: CachedRowSet is an abstract class