Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem running MySql

 
Mark Lau
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My system in my lab is a Sun Sparc SunBlade 100.
I am running Win2K *inside* Solaris 8 on this machine.
I downloaded mysql-3.23.49-win.zip and installed under the Win2K system. Every time, when I run mysql.exe at c:\mydql\bin, I get such an error message.

ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)
I run the same version of MySql at home with my PC which runs Win2K. I don't have this problem at home. Can anybody kindly educate me please?
Thanks a lot.
 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem is that the mysql daemon is not running. you need to type mysqld --port=whatever port you want. I usually use 3306. I think that is the default if you don't specify a port, though it may force you to specify a port. My win2K Server box did. mysql.exe is the client for the mysql server. If the server daemon is not running, the client can't run. Hope that helps.
 
Mark Lau
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, I got the same error message even after I run mysqld.exe, which seems to work well, at least I did not see any error message.
I also downloaded the MySql package from sunfreeware.com and pkgadded it to my Solaris 8 system. Every time I run safe_mysqld, I get the following error message:
# ./safe_mysqld
chown: unknown user id mysql
Starting mysqld daemon with databases from
/usr/local/mysql/var
Killed
020308 22:12:04 mysqld ended
#
How do I handle this then?
Thanks.
 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sounds to me like you need to start mysql.exe by passing it a username and password. Usually, when you install Mysql there is a default username called root. And the password is blank. Some versions of MySQL require passing those parameters into the client when starting it. It is late here and I know that on www.mysql.com there is a ton of documentation as to what the options are when passing in params to the client. I however can't remember them off hand. On Monday, if you still haven't got it running, I will do my best to resolve this further with you. But for now, it is late, and I am tired. Good luck this weekend with it.
 
Mark Lau
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, great. I'll try my best, will return to this forum, successful or not.
 
Mark Lau
Ranch Hand
Posts: 120
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, can somebody else help setting up MySql on my Solaris 8? Please refer to my previous posts for the problem which I encountered. Thanks a lot.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic