Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
The moose likes JDBC and Relational Databases and the fly likes Thin Driver for JDBC 2.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "Thin Driver for JDBC 2.0" Watch "Thin Driver for JDBC 2.0" New topic

Thin Driver for JDBC 2.0

jinny eom

Joined: Nov 28, 2002
Posts: 2
I have working with jdbc2.0 which comes along jdk1.3
I would like to know whether the oracle thin driver( support jdbc2.0.
I couldn’t find any comment that this thin driver supports the JDBC 2.0 at the Oracle’s Site.
I want to update the table by using the updatable resultset (ResultSet.CONCUR_UPDATABLE) with absolute, updateString and updateRow method.
But the SQLException occurred in “updateString” method.
(The code exactly follows the step and syntax written in Java API)
Please help!!!
Aamir Iqbal

Joined: Nov 29, 2002
Posts: 17
yes, i am working that thin line driver with jdk1.3, it is working.
No problem
Rene Larsen
Ranch Hand

Joined: Oct 12, 2001
Posts: 1179

'' support jdk1.2.x -> 1.3.x and therefore jdbc2.0
'ojdbc14.jar' support jdk1.4.x and therefore jdbc3.0


Regards, Rene Larsen
Dropbox Invite
jinny eom

Joined: Nov 28, 2002
Posts: 2
Thanks for your replies!!!
I will retry it.
It is sorta covered in the JavaRanch Style Guide.
subject: Thin Driver for JDBC 2.0
It's not a secret anymore!