*
The moose likes JDBC and the fly likes Need help with Jave Oracle Connection Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "Need help with Jave Oracle Connection" Watch "Need help with Jave Oracle Connection" New topic
Author

Need help with Jave Oracle Connection

Kah Wai Ong
Greenhorn

Joined: Dec 11, 2003
Posts: 2
Below is my error message when I try to connect!!!

RDB000-E : Unexpected database error.
java.sql.SQLException: ORA-00600: internal error code, arguments: [ttcgcshnd-1], [0], [], [], [], [], [], []
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:168)
at oracle.jdbc.ttc7.TTIoer.processError(TTIoer.java:208)
at oracle.jdbc.ttc7.Oall7.receive(Oall7.java:543)
at oracle.jdbc.ttc7.TTC7Protocol.doOall7(TTC7Protocol.java:1405)
at oracle.jdbc.ttc7.TTC7Protocol.fetch(TTC7Protocol.java:889)
at oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java:1681)
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1870)
at oracle.jdbc.driver.OracleStatement.executeQuery(OracleStatement.java:538)

Any idea on what I have missed out to cause this error happen??? Thanks a lot!!
[ February 20, 2004: Message edited by: Bear Bibeault ]

always Jubs
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8876
    
    8

Originally posted by Kah Wai Ong:

Any idea on what I have missed out to cause this error happen??? Thanks a lot!!

None. Help us narrow it down. You are using Oracle. There are about a dozen different products. Are you going straight to the DB or using an app server? What version of Oracle DB are you using? Is the DB local or on a server? Can you connect to the db using SQL+? Show us your connection string (feel free to hide the IP address).


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
Jamie Robertson
Ranch Hand

Joined: Jul 09, 2001
Posts: 1879

unfortunately, I don't think any java or Oracle info is gonna help us on this one
from the oracle docs:
"ORA-00600 internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]
Cause: This is the generic internal error number for Oracle program exceptions. It indicates that a process has encountered a low-level, unexpected condition. Causes of this message include:
-timeouts
-file corruption
-failed data checks in memory
-hardware, memory, or I/O errors
-incorrectly restored files
-The first argument is the internal message number. Other arguments are various numbers, names, and character strings. The numbers may change meanings between different versions of Oracle.
Action: Report this error to Oracle Support Services after gathering the following information:
-events that led up to the error
-the operations that were attempted that led to the error
-the conditions of the operating system and databases at the time of the error
-any unusual circumstances that occurred before receiving the ORA-00600 message
-contents of any trace files generated by the error
-the relevant portions of the Alter files
Note: The cause of this message may manifest itself as different errors at different times. Be aware of the history of errors that occurred before this internal error."

good luck!
Jamie
Kah Wai Ong
Greenhorn

Joined: Dec 11, 2003
Posts: 2
Ok here the scenario.
I think I have connect to the DB successfully because I can go into the logging screen.
On my 1st initial page. I have to logging in which this login screen check against 1 of the Table in my DB.
After I key in the LOGIN ID and password. this error occur.
Any idea again?!!
Saeed Amer
Ranch Hand

Joined: Jan 20, 2004
Posts: 140
Hello Kah Wai Ong,
I am not sure if were able to fix the problem (hope you did) because the last post is as of Dec 11, 2003.
Anyway, I am getting the same error message when I run my servlet that connects to Oracle (9.2.0.1) and tries to retrieve some data.
What I have found so far is that if the query returns only ONE column (single or multiple rows), it works OK. But if the query returns more than one columns (single or multiple rows), I get the error.
Seems like some problem with Oracle JDBC Thin driver. Is there someone out there who may shed some lihgt on this, please?
TIA
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Need help with Jave Oracle Connection