aspose file tools*
The moose likes JDBC and the fly likes WTK Emulator can't OTA from remote web server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Databases » JDBC
Reply locked New topic
Author

WTK Emulator can't OTA from remote web server

Daniel Moore
Ranch Hand

Joined: Dec 12, 2003
Posts: 31
Hi folks,
I'm developing a MIDP1.0 application. I have installed the WTK2.0
succesfully on linux, and the application runs fine when I use the 'Run'
and 'Run via OTA' options. However, when I push the jad and jar files to
my web server, I have issues. When I run the emulator on the command line:
emulator -Xjam
and enter in the address to the jad file, it fails with the error 'No Midlet
Suites found. Check the URL to make sure it is correct'. I've verified
that I can download the jad file with a browser. And I can see the
emulator in the logs, getting the jad file.
I've also tried the IP address and I get the same error (and see the request in the logs).
I've tried increasing the verbosity level of the emulator, but either I
target the wrong area and don't get relevant information, or I turn on
-Xverbose:all and get way too much to see what's going wrong.
I've googled on this, but found not much. I've also looked through this:
OTA doc from sun
Any ideas?
Dan


<a href="http://www.mooreds.com/weblog/" target="_blank" rel="nofollow">http://www.mooreds.com/weblog/</a>
Daniel Moore
Ranch Hand

Joined: Dec 12, 2003
Posts: 31
Oh my goodness. I'm sorry, I thought I was in the J2ME forum! Sorry. Can someone please remove this topic? I'll post it over there.
Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15286
    
    6

You can actually remove it yourself if you want. There is an Edit link you can click and then there is a checkbox for Delete. For now, I will just close this thread so that you can see my message and know for future reference.


GenRocket - A Test Data Generation Platform
 
 
subject: WTK Emulator can't OTA from remote web server
 
Similar Threads
OTA deployment issues
Trouble running "Kicking Butt" PushyMIDlet example
OTA download problem
problem with OTA download Midlet
Sun emulator can't OTA my app from a remote web server