my dog learned polymorphism*
The moose likes JDBC and the fly likes java.sql.SQLException: ORA-00600 - Anyone? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "java.sql.SQLException: ORA-00600 - Anyone?" Watch "java.sql.SQLException: ORA-00600 - Anyone?" New topic
Author

java.sql.SQLException: ORA-00600 - Anyone?

Saeed Amer
Ranch Hand

Joined: Jan 20, 2004
Posts: 140
Hello Ranchers,
I thought fix for my problem would be easy one and I was expecting tons of response. But ...
I still believe there is someone out there who would guide me through and help solve the problem (too optimistic!!!)
Cheers!
-------- prev post: problem description/background is below ---------
Hello everyone,
I am getting the following error message when I run my servlet that connects to Oracle (9.2.0.1) and tries to QUERY some data:
java.sql.SQLException: ORA-00600: internal error code, arguments: [ttcgcshnd-1], [0], [], [], [], [], [], []
I am using JBoss (3.0.6). I have narrowed down the problem and have got to the point where the problem is happening (detail below) - but I have almost no clues what is causing it.
What I have found so far is that if the query returns only ONE column (single or multiple rows), it works OK. But if the query returns more than one column (single or multiple rows), I get the error.
Seems like some problem with "Oracle JDBC Thin driver". Here is my CLASSPATH:
C:\ora92\jdbc\lib\ojdbc14.jar;
C:\ora92\jdbc\lib\classes12.jar;
C:\ora92\sqlj\lib\runtime12.jar;
C:\ora92\sqlj\lib\translator.jar;
C:\java\j2sdk1.4.2_01\bin\servlet.jar;
I added the first entry (ojdbc14.jar) as per suggestion from someone on another forum but nothing has helped so far.
Is there someone out there who may shed some lihgt on this and help fix the problem, please?
TIA
Just for information: I had Oracle8i on my PC but due to some problems with my Windows, I reinstalled the Windows/2000 (Clean install) and this time installed Oracle 9i (9.2.0.1). No there are traces of Oracle 8i stuff on my PC (as far I know - bcoz I cleaned it). I am not sure if and how JBoss is able to use Oracle8i JDBC driver (if this is the case at all).
Rudy Dakota
Ranch Hand

Joined: Jul 27, 2002
Posts: 54
Hi Saeed,
The ORA-00600 is a sort of catch-all for unforeseen errors in the Oracle kernel. That 's why Oracle allows some parameters to be added, which should help Oracle support in determining what the problem is. Its appearance seems to indicate you have moved out of the realm of 'standard' problems for which answers could be provided in this forum.
The ORA-00600 also makes it rather unlikely you 'd be facing a problem with the JDBC driver, in my opinion.
Good riddance,
Rudy
Saeed Amer
Ranch Hand

Joined: Jan 20, 2004
Posts: 140
Thanks for your input Rudy!
I strongly believe (for whatever reason) that this error is being caused by some problem with the Orcle JDBC driver.
I ran the same stuff when I had Orcle8i on my PC and everything was running fine. The problem only started when I got rid of Oracle8i and installed Oracle9i.
Also, my qeuries run OK, I am able to insert data, etc, successfully. The problem occurs only when query returns multi-column result set.
Anyways, I'll continue my struggle and post here whatever I'll find.
Thanks again!
SJ Adnams
Ranch Hand

Joined: Sep 28, 2001
Posts: 925
I'd put money on you trying to use an 8i driver to connect to a 9i database.
the 06000 errors are a bit of a red herring.
Saeed Amer
Ranch Hand

Joined: Jan 20, 2004
Posts: 140
Dear SJ Ponsardin,
Well, I never said that I am trying to use 8i driver to connect to 9i DB, did I?
All I said was I had 8i on my PC and everything was running OK. Then I uninstalled 8i and installed 9i. Since then, I am getting this error.
Thanks,
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: java.sql.SQLException: ORA-00600 - Anyone?
 
Similar Threads
Queries related to JDBC
Need help with Jave Oracle Connection
java.sql.SQLException: ORA-00600: internal error code, arguments: [ttcgcshnd-1], [0],
login error using WSAD5.1 & Oracle
java/sql/Savepoint Exception