Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
The moose likes JDBC and Relational Databases and the fly likes Having trouble with executeBatch Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "Having trouble with executeBatch" Watch "Having trouble with executeBatch" New topic

Having trouble with executeBatch

Reggie McDougal
Ranch Hand

Joined: Sep 27, 2004
Posts: 69
For some reason execute batch will not update the database, now I have tried testing the batch with a ps.setString (1, "testData") and still no cigar, it looks right to me I just can't see why the database is not updating.

error is an ArrayList by the way.

You can never drink too much
Nathaniel Stoddard
Ranch Hand

Joined: May 29, 2003
Posts: 1258
I believe setString wants a 0-indexed number as its parameter. So, you should be giving it a 0 instead of 1 -- unless I'm misunderstanding something here ....

Fisher Daniel
Ranch Hand

Joined: Sep 14, 2001
Posts: 582
Hi Reggie,
I think you should add this after you get database connection..

And Nathaniel, according to JDBC Specification, the setting parameter always start with 1 instead of 0-index.

Correct me if I am wrong...
Hope this help
Jeanne Boyarsky
author & internet detective

Joined: May 26, 2003
Posts: 33124

Daniel is correct. JDBC uses indexes starting with 1.

[OCA 8 book] [Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Other Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, TOGAF part 1 and part 2
I agree. Here's the link:
subject: Having trouble with executeBatch
It's not a secret anymore!