It's not a secret anymore!*
The moose likes JDBC and the fly likes java.sql.SQLException: Pls Help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "java.sql.SQLException: Pls Help" Watch "java.sql.SQLException: Pls Help" New topic
Author

java.sql.SQLException: Pls Help

Pol Appan
Ranch Hand

Joined: Aug 26, 2004
Posts: 144
Hello,

I have a java stored procedure called MailSend.java and using JDeveloper I deployed to Oracle 9i Database.

I am calling the stored procedure MailSend from a java class.However I am getting error :

java.sql.SQLException: ORA-06550: line 1, column 7:
PLS-00201: identifier 'MAILSEND' must be declared
ORA-06550: line 1, column 7:

Any help is highly appreciated

Thanks

Cosmos


Never take anything for granted because you never know when you will lose it
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30123
    
150

Cosmos,
It looks like there is a compile/syntax error in the stored proc.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Avi Abrami
Ranch Hand

Joined: Oct 11, 2000
Posts: 1121

Cosmos,
Is this the first time you have tried creating a java stored procedure using JDeveloper? Did you deploy it using the JDeveloper wizards?

Personally, I don't like using the wizards because:
  • I don't know what the wizard is doing
  • I don't know what to do and where to start looking when something goes wrong



  • In any case, I'm guessing that "MAILSEND" is the name of your stored procedure, and if I remember correctly, the JDeveloper wizards always wrap stored procedures in packages (but I forget where the wizard gets the package name from). So you may simply need to prefix the invocation of MAILSEND with its package name. For example, if the package name is COSMOS, then the invocation needs to be:

    It may also be that you haven't (or should I say the JDeveloper wizards haven't) granted the required permissions to the MAILSEND procedure.

    Have you checked the data dictionary (of the Oracle database) to see whether MAILSEND exists, is valid, and has the correct permissions?

    Have you tried the JDeveloper forum (part of Oracle's OTN Web site?

    Good Luck,
    Avi.
     
    I agree. Here's the link: http://aspose.com/file-tools
     
    subject: java.sql.SQLException: Pls Help
     
    Similar Threads
    Oracle9i wrong number or types of arguments in call to...
    Can a oracle Stored procedure return a cursor as a return value?
    HELP!!! - inner exception : java.sql.SQLException: ORA-06550:
    Calling a function vs a procedure on Oracle with CallableStatement
    PLS-00201: identifier 'SEC_LBIC.LDAP_VIEW_APP_LIST' must be declared