aspose file tools*
The moose likes JDBC and the fly likes JDBC driver support for MySQL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "JDBC driver support for MySQL" Watch "JDBC driver support for MySQL" New topic
Author

JDBC driver support for MySQL

Manish Hatwalne
Ranch Hand

Joined: Sep 22, 2001
Posts: 2581

I am having some problems in getting MySQL 4.1.8 to work with JDBC drivers
in - mysql-connector-java-2.0.14-bin.jar

Do these drivers work with MySQL 4.1.8? hey seem to be working fine with
4.0.14 version of MySQL. Is there any compatibility data available for all these JDBC drivers and MySQL version.

TIA,
- Manish
Pj Murray
Ranch Hand

Joined: Sep 24, 2004
Posts: 194
The first thing you should do is ensure that mm.mysql-2.0.14-bin.jar is in your Classpath.



PJ Murray

CodeFutures - Java Code Generation
http://www.codefutures.com
Manish Hatwalne
Ranch Hand

Joined: Sep 22, 2001
Posts: 2581

I have checked classpath and all such basic things, the problem is not that, all te hude codebase works with MySQL 4.0.12 on one server and 4.0.14 on another server.

I am figuring out if there are some compatibility issues with this version of JDBC drivers with MySQL 4.1.8. I am unable to obtain connection with existing working code when it is used with MySQL 4.1.8 on a new sever taht we're trying to set up.

Any pointers, help would be greatly appreciated.

TIA,
- Manish
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JDBC driver support for MySQL