permaculture playing cards*
The moose likes JDBC and the fly likes Cannot Insert Colum Into Resultset Oracle Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Databases » JDBC
Bookmark "Cannot Insert Colum Into Resultset Oracle" Watch "Cannot Insert Colum Into Resultset Oracle" New topic
Author

Cannot Insert Colum Into Resultset Oracle

knock knock
Greenhorn

Joined: Jul 22, 2005
Posts: 1
Hi Friends,
Any help regarding this would be welcomed.
Please Help me.I am new to J2EE Programming.Our web project which we deploy on Tomcat 5.0.28 works perfectly fine when connected to Sybase ASA Database we have a new client requirement for which we have to connect it using Oracle 9i as the database.For doing the same i installed Oracle 9i(i have also tried with 8i)on my system copied the JDBC driver to the correct directory in Tomcat it got connected and is retriving data from the database perfectly.But when we try to insert a colum in the datbase using a result set it fails .The ResultSet rs is created properly(No Exception Thrown there) then the statement rs.moveToInsertRow(); also goes ahed without a problem but after taking the values when rs.insertRow(); is executed it throws an exception i.e. ORA-01732: data manipulation operation not legal on this view which I think is an exception from the oracle side whereas we are not manipulating any views we are inserting directly into the database tables. I would like to mention that to connect to oracle we are using the classes12.jar driver and the path for the same in the code is oracle.jdbc.driver.OracleDriver i have also tried it with the thin driver but same error reported.

[edited to remove "urgent" from subject]
[ July 22, 2005: Message edited by: Jeanne Boyarsky ]
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 29240
    
139

"knock knock",
We're pleased to have you here with us in the JDBC forum, but there are a few rules that need to be followed, and one is that proper names are required. Please take a look at the JavaRanch Naming Policy and adjust your display name to match it.

In particular, your display name must be a first and a last name separated by a space character, and must not be obviously fictitious.

Note that questions from users with invalid display names are less likely to get answered.

Thanks,
Jeanne
Forum Bartender


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot Insert Colum Into Resultset Oracle
 
Similar Threads
Large data entry issue
UTF8 conversion
WSAD to ORACLE 9i connection
Web service with a jdbc connection
Connecting To Database