This week's book giveaway is in the JDBC forum.
We're giving away four copies of Make it so: Java DB Connections & Transactions and have Marcho Behler on-line!
See this thread for details.
The moose likes JDBC and Relational Databases and the fly likes error msg UnsatisfiedLinkError t2cGetCharSet Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Make it so: Java DB Connections & Transactions this week in the JDBC forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "error msg UnsatisfiedLinkError t2cGetCharSet" Watch "error msg UnsatisfiedLinkError t2cGetCharSet" New topic

error msg UnsatisfiedLinkError t2cGetCharSet

Atlas Cot

Joined: Sep 12, 2005
Posts: 5
Exception in thread "main" java.lang.UnsatisfiedLinkError: t2cGetCharSet
at oracle.jdbc.driver.T2CConnection.t2cGetCharSet(Native Method)
at oracle.jdbc.driver.T2CConnection.getCharSetIds(
at oracle.jdbc.driver.T2CConnection.logon(
at oracle.jdbc.driver.PhysicalConnection.<init>(
at oracle.jdbc.driver.T2CConnection.<init>(
at oracle.jdbc.driver.T2CDriverExtension.getConnection(
at oracle.jdbc.driver.OracleDriver.connect(
at java.sql.DriverManager.getConnection(
at java.sql.DriverManager.getConnection(
at JdbcTest.main(
Java Result: 1

thanks in advance
[ October 21, 2005: Message edited by: Bear Bibeault ]
Jeanne Boyarsky
author & internet detective

Joined: May 26, 2003
Posts: 32848

Welcome to JavaRanch!

Which Oracle driver do you have in your classpath?

[OCA 8 book] [Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Other Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, TOGAF part 1 and part 2
David O'Meara

Joined: Mar 06, 2001
Posts: 13459

Can we get some more details? ie what OS are you running, what is the jdbc-url, oracle version, oractle driver JAR, anything else of note?

The only time I can rememeber something similar was years back on Linux using the Oracle type-2 driver when the Oracle client wasn't installed correctly. I'd also check that you are using the most up-to-date oracle driver.
Damien Paque

Joined: Nov 09, 2005
Posts: 1

Is the problem resolved? Because I 've the same. It appears when I use MapViewer to get the result of a spatial querry.
I use Oracle 10g with MapViewer

Thanks for your response.
ruler Dershmoozelat

Joined: Mar 19, 2009
Posts: 1
This is old, but there's a solution on the Oracle forums here:

There are a couple of possible solutions on that thread, but the one that solved my instance of this "java.lang.UnsatisfiedLinkError: t2cGetCharSet" error was removing duplicate entries in my PATH environment variable that pointed to Oracle bin directories. In my case, I had C:\OraHome_1\bin, which I wanted, but I also had an old OracleXE\bin (this isn't the actual path, I can't remember what it was) entry. After I removed OracleXE\bin from my path, it worked like a charm.
I agree. Here's the link:
subject: error msg UnsatisfiedLinkError t2cGetCharSet
It's not a secret anymore!