wood burning stoves 2.0*
The moose likes JDBC and the fly likes Savepoint Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Databases » JDBC
Bookmark "Savepoint " Watch "Savepoint " New topic
Author

Savepoint

Sonali Salunkhe
Greenhorn

Joined: Feb 02, 2006
Posts: 11
Hello Eveyone,

I am doing this instruction:
Savepoint sp1=con.setSavepoint("one");

on jdk1.4 . I want to know whether jdk1.4 supports Savepoint feature?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42042
    
  64
Instead of addressing your question directly (which you can easily do yourself by consulting the javadocs for Java 1.4), I'll just point out that the more interesting question is whether the JDBC driver and the database you use support this feature. The JDK only defines this interface, but the DB and the driver together implement it.


Ping & DNS - my free Android networking tools app
Nicolas Stern
Ranch Hand

Joined: Apr 26, 2002
Posts: 57
Can't tell for other RDBMS.

Oracle JDBC Drivers supports this feature for server Release 9i and more recent, and JDK1.4

Look
here

Cheers
Sonali Salunkhe
Greenhorn

Joined: Feb 02, 2006
Posts: 11
Fine Thanks.
I used the type 4 driver for oracle,it is loading properly ,Even there is no problem while making a connection.

[I]




I have written the above code.I have the table SavePintDemo with the field id, name & salary.
The output it generates using jdk1.5 as :

Type4 driver is registered
Connection established
Exception in thread "main" java.lang.AbstractMethodError: oracle.jdbc.driver.Ora
cleConnection.setSavepoint(Ljava/lang/String Ljava/sql/Savepoint;
at SavePointDemo.<init>(SavePointDemo.java:41)
at SavePointDemo.main(SavePointDemo.java:78)

[/I]

Thanks in advance.
Sonali Salunkhe
Greenhorn

Joined: Feb 02, 2006
Posts: 11
Hi everyone,

Actually i tried the savepoint ( above given code) using type4 , type1 driver. For type1 -- It doesn.t support this feature.
For type4-- It givees me abstartctmethosd--above ,mentioned exeption.

Can anybody tell me which driver supports this feature?

note: The savepoint feature works with oracle DB.I tried it.

Thanks .
stu derby
Ranch Hand

Joined: Dec 15, 2005
Posts: 333
Savepoint support was supposedly added in the 9.2.0.1 version of the Oracle driver, according to the README.

The 10gr2 driver was the first version Oracle-certified for Java 1.5 (though there's no particular reason I know of that older drivers shouldn't work with it).
 
GeeCON Prague 2014
 
subject: Savepoint