aspose file tools*
The moose likes JDBC and the fly likes JDBC con with Oracle8i & MySql5.0 in swing Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Databases » JDBC
Bookmark "JDBC con with Oracle8i & MySql5.0 in swing" Watch "JDBC con with Oracle8i & MySql5.0 in swing" New topic
Author

JDBC con with Oracle8i & MySql5.0 in swing

vikram malihan
Greenhorn

Joined: Jun 13, 2006
Posts: 5
Hello Ranchers...
I'm using JAVA Swing and want to use "Oracle8i" or MySql5.0" as a data base and the webserver using is Apache Tomcat. I have completed the project in Ms-Acces but i want to use "Oracle8i" or MySql5.0"

1. I have no idea for Dreiver name and any aditional file required for the connection with "Oracle8i" & MySql5.0".

2. and whitch conection string to write in "DriverManager.getConnection (???)"

3 can we make DSN for "Oracle8i" & MySql5.0" too. if yes what are the steps for making DSN in windows envirenment

Now ranchers.. You all requested to help me, to do.. so
if we want to edit some configuration file. also .. help me to do so..

Thanks in advance

regards

vikram


vikram<br />SCJP 1.5<br />delhi
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336


1. I have no idea for Dreiver name and any aditional file required for the connection with "Oracle8i" & MySql5.0".

Depends on the driver you use. Oracle comes with a driver - read the "JDBC Developer's Guide and Reference" to find out how to use it. MySQL has this. Again you should really read the accompanying documentation to get you going.


2. and whitch conection string to write in "DriverManager.getConnection (???)"

This will be covered in your Driver's documentation.


3 can we make DSN for "Oracle8i" & MySql5.0" too. if yes what are the steps for making DSN in windows envirenment

Use a type 4 driver - then you won't need any other configuration.



(BTW: Oracle 8i isn't supported any more. If you wan't to use Oracle, the oldest version you should be using is 9i.)


JavaRanch FAQ HowToAskQuestionsOnJavaRanch
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JDBC con with Oracle8i & MySql5.0 in swing