aspose file tools*
The moose likes JDBC and the fly likes DSRA9110E: ResultSet is closed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "DSRA9110E: ResultSet is closed" Watch "DSRA9110E: ResultSet is closed" New topic
Author

DSRA9110E: ResultSet is closed

Jayashree Menon
Greenhorn

Joined: Jul 26, 2004
Posts: 4
Our application which was on Websphere5.1 and Oracle 9i was recently upgraded to Websphere6.1.0.13 and Oracle 10g. With the same set of Code and other setting such as Datasopurces, connection pooling etc, we are getting an error as :

DSRA9110E: ResultSet is closed
Instead of the complete code I will post the logic and some pseudo code on this.

Dilip Mallik
Ranch Hand

Joined: Sep 19, 2008
Posts: 40
Hi Jayshri,

I have also faced this problem in my application , I used to get connection error from the method where connection object was retrieved can you put sop in
getConnection() and check if before returning the connection object the object is not Null
Jayashree Menon
Greenhorn

Joined: Jul 26, 2004
Posts: 4
Thank You Dilip.
We did put in a lot of SOPs and checked, but the connection object is not null or closed. Even the ResultSet is not null. Which is what is strange.
I hope we get a resolution for this quickly.
Shailesh Chandra
Ranch Hand

Joined: Aug 13, 2004
Posts: 1081

Are you using stateless session bean or stateful session bean ? my another
question is why are you having connection and member variable of class.


Assuming you are using stateless session bean. The instance of stateless session beans are shared among multiple request. How do you ensure that other request will not cause problem like closing connction etc ect...

Can you give a try to your code having connection as local variable....

Shailesh


Gravitation cannot be held responsible for people falling in love ~ Albert Einstein
Jayashree Menon
Greenhorn

Joined: Jul 26, 2004
Posts: 4
Many Thanks Shailesh.
However none of the above apply to the scenario. We did a lot of Research and testing at our end. Following are the scenarios and the conclusions.

We tested the application by connecting to DataSource of Oracle 9i. It worked perfectly fine. No resultsets were closed.

The same piece of code connecting to Oracle 10g datasource fails.

Next we tried connecting to Oracle 10g through DriverManager instead of Datasource. It worked perfectly fine.

Our conclusion is that Oracle 10g datasource has some issues which we are not clear about. Is it because we are updating the same table as that of the resultset in the same connection that the resultset is getting closed? We are not too sure of this. Would be glad if anyone can shed some light on this.

Thanks a lot
Jayashree Nair
 
 
subject: DSRA9110E: ResultSet is closed