File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JDBC and Relational Databases and the fly likes JDBC resultset exusted error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Bookmark "JDBC resultset exusted error" Watch "JDBC resultset exusted error" New topic

JDBC resultset exusted error

trupti nigam
Ranch Hand

Joined: Jun 21, 2001
Posts: 614

I am having two different environments for development in my company and we connect to two different databases.
The issue I am seeing is, in one environment my query runs fine returning the expected data. But in second environment, even though the query returns the data (when I ran this in Toad SQL window) , the resultSet is not null but it never enters the while loop (i.e. while ( loop). I tried putting debugging statemnets and i found that I get resultset exusted error. What can be the reason that in one environment I don't see any issue with my query and code and in another even though data exists , there are issues like exuated resultset error.

Shailesh Chandra
Ranch Hand

Joined: Aug 13, 2004
Posts: 1082

Originally posted by trupti nigam:
even though the query returns the data (when I ran this in Toad SQL window)

If query is returning data in toad, this means database might not be a cause of problem, Can be have a look on code...?


Gravitation cannot be held responsible for people falling in love ~ Albert Einstein
I agree. Here's the link:
subject: JDBC resultset exusted error
It's not a secret anymore!