wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes j2ee on winME versus winServer2000 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "j2ee on winME versus winServer2000" Watch "j2ee on winME versus winServer2000" New topic
Author

j2ee on winME versus winServer2000

causenge cangin
Greenhorn

Joined: Apr 21, 2001
Posts: 4

In windows Server 2000, I could run
1 "j2ee -verbose" and 2 "deploytool" with no problem.
On windows ME(Millileum edition), running "j2ee -verbose" gives:
Out of environment space
In the downloaded file C:\j2sdkee1.3\bin\j2ee.bat, it calls
C:\j2sdkee1.3\bin\setenv.bat ; which sets many environment variables. windows ME cannot handle more than 8 environment
variables; so even if the classpath is correct, I get:
C:\>j2ee -verbose
Out of environment space
Out of environment space
Bad command or file name
C:\>
How do we get around this?
Michael Zhao
Ranch Hand

Joined: Sep 19, 2000
Posts: 77
did u try to change the memory size in the properties of MS-DOS?
I use j2sekee1.2.1 in winme and after changed the memory size, the same problem disappeared.
zhao


SCJP,SCWCD,SCMAD,OCP9I, SCEA
causenge cangin
Greenhorn

Joined: Apr 21, 2001
Posts: 4
How can the MSDOS prompt configured so that it has a vertical scrollbar? Right now, I can only see one screen or the current screen; cannot scroll back to see previous output.
Originally posted by Weishe Zhao:
did u try to change the memory size in the properties of MS-DOS?
I use j2sekee1.2.1 in winme and after changed the memory size, the same problem disappeared.
zhao

causenge cangin
Greenhorn

Joined: Apr 21, 2001
Posts: 4
(0) How can shell be configured in winME to have a vertical
scroll bar?
(1) in winServer, the control Panel-> System-> Environment Var
allows one to permanently set the %PATH% or any env variables
for all shells. In winME, I cannot find a way to permanently
set Environment variables for ALL shells.
(2) After setting memory in MS-DOS prompt to maximum, in a shell
I typed:
set CPATH=C:\J2SDKEE1.3\LIB\J2EE.JAR;C:\J2SDKEE1.3\LIB;C:\j2sdkee1.3\bin;C:\jdk1.3.0_02\bin;.
set CLASSPATH=C:\J2SDKEE1.3\LIB\J2EE.JAR;C:\J2SDKEE1.3\LIB;C:\j2sdkee1.3\bin;C:\jdk1.3.0_02\bin;.
set PATH=C:\j2sdkee1.3\bin;C:\j2sdkee1.3;C:\jdk1.3.0_02\bin;C:\jdk1.3.0_02;%PATH%;.
set JAVA_HOME=C:\jdk1.3.0_02
set J2EE_HOME=C:\j2sdkee1.3
But still I get errors:
C:\WINDOWS>C:\J2SDKEE1.3\BIN\J2EE.BAT
Bad command or file name
C:\WINDOWS>j2ee -verbose
Bad command or file name
(3) What do the symbols %1 and %2 in the script C:\J2SDKEE1.3\BIN\J2EE.BAT mean? It looks like the script translate %1 to
verbose and %2 to nothing; for which MS DOS complain.
For example, when I manually execute J2EE.BAT , I got:
C:\WINDOWS>C:\jdk1.3.0_02\bin\java -Xmx128m -Dorg.xml.sax.parser=org.xml.sax.
helpers.XMLReaderAdapter -Dorg.xml.sax.driver=org.apache.crimson.parser.XMLReade
rImpl -Djms.home=C:\j2sdkee1.3 -Dcom.sun.jms.service.jdbc.dbpath=C:\j2sdkee1.3\r
epository\\db\ -Djms.properties=C:\j2sdkee1.3\config\jms_service.properties -Dja
va.security.policy==C:\j2sdkee1.3\lib\security\server.policy -Djava.security.aut
h.login.config=C:\j2sdkee1.3\lib\security\login.config -Dcom.sun.enterprise.home
=C:\j2sdkee1.3 -classpath "C:\j2sdkee1.3\lib\system\cloudscape.jar;C:\j2sdkee1.3
\lib\system\tools.jar;C:\j2sdkee1.3\lib\cloudscape\RmiJdbc.jar;C:\j2sdkee1.3\lib
\cloudscape\client.jar;C:\j2sdkee1.3\lib\classes;C:\j2sdkee1.3\classes;C:\j2sdke
e1.3\lib\j2ee.jar;C:\j2sdkee1.3\lib\locale;C:\jdk1.3.0_02\jre\lib\rt.jar;C:\jdk1
.3.0_02\lib\tools.jar;.;C:\J2SDKEE1.3\LIB\J2EE.JAR;C:\J2SDKEE1.3\LIB;.;C:\j2sdke
e1.3\lib\jhall.jar" com.sun.enterprise.server.J2EEServer -verbose

Java 2 Enterprise Edition Server
Options:
-verbose Redirect all logging output to the current shell.
-help Print this help message.
-version Print the version.
-singleVM Deploys all beans in this process.
-multiVM Deploys all beans in a jar file in a new process.
-stop Stop the J2EE server.
Michael Zhao
Ranch Hand

Joined: Sep 19, 2000
Posts: 77
hi,
1.winme just like win98, go to c:\autoexec.bat and set the classpath then restart the computer.
0.in properties of MS-DOS, go to screen and change the size to 50 lines
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: j2ee on winME versus winServer2000
 
Similar Threads
problem starting J2EE server
Problem with starting the j2ee server
Help..... set the Path....
problem during building & running j2ee sdk
can't seem to get j2ee to start