aspose file tools*
The moose likes EJB and other Java EE Technologies and the fly likes Problem with starting J2EE server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Problem with starting J2EE server" Watch "Problem with starting J2EE server" New topic
Author

Problem with starting J2EE server

Priya Chetlur
Greenhorn

Joined: Feb 20, 2001
Posts: 20
Hi All,
I am having trouble starting and running the J2EE server. I have windows 98. I have set the path variable to C:\j2sdkee1.2.1\bin. I have also set the environment variables J2EE_HOME and JAVA_HOME. When i issue command cloudscape -start, the following is dispalyed and nothing happens after that. I mean it doesn't come back to the prompt.
----------------------------------------------------------------
C:\j2sdkee1.2.1>cloudscape -start
Thu May 31 18:20:19 SGT 2001: [RmiJdbc] COM.cloudscape.core.JDBCDriver registere
d in DriverManager
Thu May 31 18:20:19 SGT 2001: [RmiJdbc] Binding RmiJdbcServer...
Thu May 31 18:20:19 SGT 2001: [RmiJdbc] No installation of RMI Security Manager.
..
Thu May 31 18:20:19 SGT 2001: [RmiJdbc] RmiJdbcServer bound in rmi registry
----------------------------------------------------------------

Where as when i issue the command j2ee -verbose, the following is displayed:
-----------------------------------------------------------------
C:\j2sdkee1.2.1>j2ee -verbose
J2EE server Listen Port: = 1049
Naming service started: :1050
Published the configuration object ...
Binding DataSource, name = jdbc/Cloudscape, url = jdbc:cloudscape:rmi:Cloudscape
DB;create=true
org.apache.tomcat.core.DefaultServlet: init
org.apache.jasper.runtime.JspServlet: init
Web service started: 9191
org.apache.tomcat.core.DefaultServlet: init
org.apache.jasper.runtime.JspServlet: init
Web service started: 8000
Web service started: 7000
J2EE server startup complete.
----------------------------------------------------------------

I want to know what this means. Has the J2EE server started properly. Why does it get stuck when i start cloudscape? Can anyone please diagnose the problem and suggest a solution.
Thanks in advance,
Priya
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

when you start cloudscape, it doesn't come back to the prompt. This is normal behaviour.

If you want to shut it down, you have to open a new DOS window and type the command. At that time, the first DOS window closes by itself.

From the J2EE server startup, everything looks normal. There are no error messages in either the Cloudscape or J2EE windows. What makes you think they are not working?

Are you having problems?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with starting J2EE server
 
Similar Threads
J2EE server still crashes
J2EE server crashes
J2EE server still crashes
can't seem to get j2ee to start
Websphere 6.0.2 localhost 9080 does not connect