Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

session time out for EJB's..

 
rajesh mysore
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I am unable to set the session timeout for statefull session bean in deployment descriptor, ie in XML.
In our appln, we are using Iplanet as web server and Weblogic as appserver. we are able to set session timeout in Iplanet configuraion menu, but not able to set for bean in the descriptor. After defaul time, the EJB container deletes the bean.
Now when i try to invoke the handle(of statefull session bean) thru a remote object from the servlet say after some time,(the time greater than session time)(The servlet is invoked from the front end) I am getting NoObjectFoundException.
session timed out is happening. Kindly le me know how to set the session timeout for statefull bean in deployment descriptor so that container reads it and act accordingly.
Thanks,
good day,
Rajesh

 
gupta boddu
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry I might not be able to help you as I am new to this.
I would like to know one thing. Please tell me how you are using iplanet web server with weblogic server.
We are going to have a similar scenario. We have the iplanet web server running cgi perl scripts and static html pages. We need to deploy EJB for which we are planning for weblogic.
Please tell me your experience with it.
1. How to integrate the Iplanet with weblogic.
2. How is the performance?
3. Any other issues?
4. How about using Iplanet web server with Iplanet app server?
Thank you.
 
Manjunath B.S
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi Rajesh,
In weblogic.properties you have a line called,
"weblogic.httpd.session.enable=true".After this line you can
add a property called "weblogic.httpd.session.timeoutSecs"
and you can set a timeout in secs like,
"weblogic.httpd.session.timeoutSecs=300".
The minimum is 1, maximum is Integer.MAX_VALUE.
Hope this helps,
Manjunath

 
rajesh mysore
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Manjunath,
I have some clarifications,
The session time ssetting in the Weblogic properties would suffice the purpose if we are using weblogic as webserver. But instead, we are using Weblogic as appserver. The session time setting is done at Iplanet( we are using IPlanet as webserver) successfully. But the session time out features provided in the Deployment Descriptors(i think we have to mention the properties of the statefull session bean in the XML Deployment descriptors) is the requirement for me.
If you can let me about this, If would be of a great help.
Thanks,
Rajesh.
 
binu sukumar
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rajesh
There is an xml tag in the descriptor, namely 'idle-timeout-interval'. You may specify the time interval in seconds as the value for this attribute. Then, the beans will not be deleted by the container before the specified time elapse.
We have used this successfully in our project.
 
Manjunath Subramanian
Ranch Hand
Posts: 236
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi all,
Thanks for the information binu!!
I had asked this question to a lot of people and nobody had any
clue about it.
regards,
Manjunath Subramanian
 
DAYANAND BURAMSHETTY
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
U have to write session timeout period in the ...\config\mydomain\applications\DefaultWebApp_myserver\WEB-INF\web.xml.
web.xml
-------------
.....

< session-config >
< session-timeout > 54 </session-timeout >
</session-config >

.....

[This message has been edited by DAYANAND BURAMSHETTY (edited August 10, 2001).]
 
binu sukumar
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, Dayanand
I think there is a confusion.
We were referring to the time out of session beans within the ejb container, not the web server timeout.
For session beans, time out is to be mentioned in the xml file used for deployment, namely 'weblogic-ejb-jar.xml'.
In this file, you have to make an entry that looks something like this:
<weblogic-ejb-jar>
<weblogic-enterprise-bean>
<ejb-name>myBean</ejb-name>
<caching-descriptor>
<max-beans-in-free-pool>100</max-beans-in-free-pool>
<idle-timeout-seconds>3000</idle-timeout-seconds>
</caching-descriptor>
................
................
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic