This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes EJB and other Java EE Technologies and the fly likes HELP!!Strange J2EE deployment error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "HELP!!Strange J2EE deployment error" Watch "HELP!!Strange J2EE deployment error" New topic
Author

HELP!!Strange J2EE deployment error

karthik suresh
Greenhorn

Joined: Jul 01, 2001
Posts: 6
hi ,
i am doing a simple ejb program which has to print hello on console.
i have compiled the home interface,remote interface and the bean successfully.
i have added the classes to make the jar file and set up the JNDI name.
but when i am deploying ,i am getting the following error:
"There was a deployment error.java.rmi.ServerException: RemoteException occured in sever thread; nested exception is: java.rmi.RemoteException: Error saving/opening" This error pops up as a message box during the "Deployment Progress Screen". The main window states: "Deployment Error: Bad mapping of key {0} to class {1}; not found: com.sun.enterprise.deployment.xml.ApplicationNode"
i am using jdk1.2 and
j2eesdk 1.2 version.
please help, i'm not able to make heads or tails of it.
this is the output of the results.txt file
***********************************************************
No Test Run. Fix error before continuing.
Error: ** Error trying to process file: Hello.ear
Check the Hello.ear and META-INF/application.xml for matching content validity: Bad mapping of key {0} to class {1}, not found: com.sun.enterprise.deployment.xml.ApplicationNode.
***********************************************************
thanks in advance .
Rajakumar Makapur
Greenhorn

Joined: Jun 23, 2001
Posts: 13
Hi
even i am getting the same problem,
are u able to solve the problem.
pls let me know.
regards
Rajakumar.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: HELP!!Strange J2EE deployment error
 
Similar Threads
Deployment Error using j2ee1.2
Error running CMP entitybean on weblogic6.0
TO: Matthew Roth!! About your EJB Deployment Problem...
Deploytool
Error in Deploying App using J2EE