aspose file tools*
The moose likes EJB and other Java EE Technologies and the fly likes Configure J2SDKEE for W2K Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Configure J2SDKEE for W2K" Watch "Configure J2SDKEE for W2K" New topic
Author

Configure J2SDKEE for W2K

Jeremy Donaldson
Greenhorn

Joined: Jun 21, 2001
Posts: 11
I've recently downloaded the J2EE framework and have begun working through some tutorials. I've tried to compile some EJB's but with no success. I've tried setting my classpath and path variables but again with no success. I've reviewed other threads illustrating what to do. But I was hoping someone would please give me detail instructions as to what variables to set and when? Again I'm using Windows 2000 professional.
Thanks,
Jeremy
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

Without knowing what compile errors you're getting, I'd say the most likely cause is that j2ee.jar is not in your classpath.

Right click mycomputer, properties, advanced, environment variables and select classpath (either from the top or bottom list) and click edit. Add the path to the j2ee.jar package in your j2sdkee download (probably c:/j2sdkee/lib/j2ee.jar) If there isn't a classpath entry, click "new" and enter the information.

If you're using an IDE, make sure it uses the system classpath. JBuilder does not, for example, so you'd need to add a new library. I think in Forte, you'd need to mount a new filesystem.

Another thing to check in regards to j2ee development is to ensure you don't have some extra jars in your classpath that might contain deprecated API's. Many people on this forum have had trouble with compiling, and they eventually find a very old version of servlet.jar somewhere in their classpath.

if you're having trouble starting the RI server, check that you do not have a service running that is using the specified ports (for example, you shouldn't run IIS or Tomcat at the same time)
Services are found:
Start/Settings/Control Panel/Administrative Tools/Services
Jeremy Donaldson
Greenhorn

Joined: Jun 21, 2001
Posts: 11
Thanks for the message. I've since been able to set my variables and everything seems to be working correctly. However, I'm not familiar with the RI server that you made mention of, did that come packaged with the download and how would that be used.
Thanks,
Jeremy
Dallas Hockley
Greenhorn

Joined: Aug 30, 2001
Posts: 3
The RI server he refers to is the Reference Implementation server, which will start when you run j2ee in the SDK. So you're actually running it already if everything is working correctly. :-)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Configure J2SDKEE for W2K