my dog learned polymorphism*
The moose likes EJB and other Java EE Technologies and the fly likes beginner's question Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "beginner Watch "beginner New topic
Author

beginner's question

patrick tang
Ranch Hand

Joined: Dec 16, 2001
Posts: 44
hi all,
i followed sun's j2ee tutorial and installed j2eesdk1.3.1. originally i have jdk1.3. i also set the environment variable JAVA_HOME, J2EE_HOME
and PATH. the problem is that when i run j2ee -verbose, it gives me the following message:
J2EE server listen port:1050
Naming service started:1050
Exception at thread "main" java.lang.NoSuchMethodError
at com.sun.corba.ee.internal.corba.AnyImpl.createTypeCodeForClass(AnyImpl.java:1256)
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.createTypeCode(ShutdownUtilDelegate.java:223)
at com.sun.corba.ee.internal.iiop.ShutdownUtilDelegate.writeAny(ShutdownUtilDelegate.java:178)
at javax.rmi.CORBA.Util.writeAny(Util.java:80)
at org.omg.stub.com.sun.enterprise.naming._SerialContextProvider_Stub.rebind(Unknown Source)
at com.sun.enterprise.naming.SerialContext.rebind(SerialContext.java:188)
at com.sun.enterprise.naming.SerialContext.rebind(SerialContext.java:202)
at javax.naming.InitialContext.rebind(InitialContext.java:370)
at com.sun.enterprise.naming.NamingManagerImpl.publishObject(NamingManagerImpl.java:192)
at com.sun.enterprise.naming.NamingManagerImpl.publishObject(NamingManagerImpl.java:149)
at com.sun.enterprise.server.J2EEServer.bindObject(J2EEServer.java:718)
at com.sun.enterprise.server.J2EEServer.createServerObject(J2EEServer.java:473)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:244)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:972)
i've checked the documentation but still have no idea what causes this error. can somebody pls give me a hint? thanks in advance
Tualha Khan
Ranch Hand

Joined: Nov 22, 2000
Posts: 287
One of my friends had a similar problem. All he did to solve it was re-installed j2ee. If you have the j2ee sdk handy (like downloaded it in office where the net is fast(i guess)), then I suggest you acquire the sdk again and then try to re-install.
Bye,
Tualha Khan


SCJP2, BEA WLS 6.0, DB2 UDB 7.1
patrick tang
Ranch Hand

Joined: Dec 16, 2001
Posts: 44
thanks tualha for the help. i'll download
it again and reinstall it.
patrick tang
Ranch Hand

Joined: Dec 16, 2001
Posts: 44
i tried to reinstall and still got the same problem. does anybody know whats going on?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: beginner's question