wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes Problem with calling of servlet from browser?? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Problem with calling of servlet from browser??" Watch "Problem with calling of servlet from browser??" New topic
Author

Problem with calling of servlet from browser??

Bikash Paul
Ranch Hand

Joined: Dec 04, 2001
Posts: 342
Hi all friends,
Iam new j2ee server i tried to deploy one simple servlet in j2ee server and it deployed but when I call that servlet from browser (IE5) through url("http://127.0.0.1:8000/servlet/test" where "test" is my name of servlet)it is giving me error "HTTP-404 file not found".I just explaining how I deployed my servlet through deploytool:-
1.From file menu I create "New Application"
2.From file menu I create "New Web Component"
3.Clicking on next button I select my "Application Name" and I give give war file name and by clicking on "Add" button of content field and I skip first dialog box by clicked on "next" button coz I don't want to select "html,jsp and gif" and in second dialog box I select my servlet class file and clicked on "finish" button.
4.clicking on next button I select Radio button of servlet.
5.By clicking on next button I select my servlet class file name and give my "web component display name" and keep -1 of "Start up load sequence position" and by clicking on finish button I come out from that dialog box.
6. After that I set my "context Root" by selecting my application name and by click on
"Web context" button and i put name of context root "servlet".And j2ee server also shows message
"Created context:/servlet"
7.After that I deployed my servlet by selecting
" Deploy Application.." from Tool menu.
And web.xml file which deploy tool created:-
<?xml version="1.0" encoding="Cp1252"?>
<!DOCTYPE web-app PUBLIC '-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN' 'http://java.sun.com/j2ee/dtds/web-app_2.2.dtd'>
<web-app>
<display-name>web app</display-name>
<description>no description</description>
<servlet>
<servlet-name>test</servlet-name>
<display-name>test</display-name>
<description>no description</description>
<servlet-class>test</servlet-class>
</servlet>
<session-config>
<session-timeout>30</session-timeout>
</session-config>
</web-app>

Can any one plz guide me where I have done a mistake due to which I couldn't call my servlet from browser through url.And My second question is I couldn't understand "Start up load sequence position".I just keep it in -1.
Regards
Bikash
[ June 03, 2002: Message edited by: Bikash Paul ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with calling of servlet from browser??