File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes EJB and other Java EE Technologies and the fly likes EJB accessing Problem in Welogic 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "EJB accessing Problem in Welogic 6.1 " Watch "EJB accessing Problem in Welogic 6.1 " New topic

EJB accessing Problem in Welogic 6.1

sunil kumar sarayar

Joined: Aug 13, 2002
Posts: 2
Hi All,
I am getting problem while accessing entity bean through remote client. I deployed one entity bean in weblogic 6.1. when i try to access that bean through java class(client), It give me error :-
javax.naming.CommunicationException. Root exception is weblogic.socket.UnrecoverableConnectException: [Login failed: 'Incompatible version:Incompatible versions - this server: client:5.1.0]
at weblogic.socket.Login.checkLoginSuccess(
at weblogic.socket.JVMSocketT3.connect(
at weblogic.socket.JVMAbbrevSocket.connect(
at weblogic.socket.JVMSocketManager.create(
at weblogic.rjvm.ConnectionManager.findOrCreateSocket(
at weblogic.rjvm.ConnectionManager.bootstrap(
at weblogic.rjvm.ConnectionManager.bootstrap(
at weblogic.rjvm.RJVMManager.findOrCreateRemoteInternal(
at weblogic.rjvm.RJVMManager.findOrCreate(
at weblogic.rjvm.RJVMFinder.findOrCreateRemoteServer(
at weblogic.rjvm.RJVMFinder.findOrCreate(
at weblogic.rjvm.ServerURL.findOrCreateRJVM(
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(
at weblogic.jndi.WLInitialContextFactory.getInitialContext(
at javax.naming.spi.NamingManager.getInitialContext(
at javax.naming.InitialContext.getDefaultInitCtx(
at javax.naming.InitialContext.init(
at javax.naming.InitialContext.<init>(
at customer.getInitialContext(
at customer.main(
I used getInitialContext method as follows :-
Properties p = new Properties();
p.put(Context.INITIAL_CONTEXT_FACTORY, "weblogic.jndi.WLInitialContextFactory");
p.put(Context.PROVIDER_URL, "t3://localhost:8001");
return new javax.naming.InitialContext(p);
Any body have idea about it >>
Plz Help me to solve this proble
Thanks In Advance
Sethu V

Joined: Aug 06, 2002
Posts: 10
Hi sunil
do u have both the weblogic5.1 and 6.1 installed on ur system and r u sure the port no is 8001. coz the default port no for weblogic is 7001
sunil kumar sarayar

Joined: Aug 13, 2002
Posts: 2
Hi Sethu,
TX. Yes, I have both web logic version but using different port: For weblogic5.1 � port 7001 and Weblogic6.1- Port 8001.
Whenever I tried to access same Entity Bean or other bean(Session) through jsp/Servlet , it�s working perfectly. This Problem is coming with java client only (simple java standalone class) whenever tried to access.
Rahul Mahindrakar
Ranch Hand

Joined: Jul 28, 2000
Posts: 1864
Please have this moved to Weblogic Forum.
Dave Landers
Ranch Hand

Joined: Jul 24, 2002
Posts: 401
Make sure your client classpath is using the weblogic.jar for the same version as the server.
So if your client is trying to talk to a 6.x server, have the 6.1 version of weblogic.jar in classpath.
It looks like your client classpath has a 5.1 weblogic.jar in classpath and is trying to communicate with a 6.1 version server.
I agree. Here's the link:
subject: EJB accessing Problem in Welogic 6.1
It's not a secret anymore!