permaculture playing cards*
The moose likes EJB and other Java EE Technologies and the fly likes J2EE Tutorial - Converter Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "J2EE Tutorial - Converter" Watch "J2EE Tutorial - Converter" New topic
Author

J2EE Tutorial - Converter

Mike Warren
Greenhorn

Joined: Oct 22, 2002
Posts: 4
Hi,
I'm having problems with the "Getting Started", Converter app. in Sun's J2EE tutorial. I did have it working, but have now returned to it in order to refresh my memory before continuing, and can't get it to work.
I've tried uninstalling the application. Stoping the j2ee server and running "cleanup". I've restored the original tutorial directory, and worked through the tutorial step, by step, but still get errors, when trying to run the web client by directing my browser to "http://localhost:8000/converter/index.jsp".
The errors I get from the verifier seem to suggest that class's ConverterHome and Converter can't be found - but I can't see anything wrong in my setup :-

If its of any help I get the following errors displayed in Internet Explporer:-

.. and so on, with the following further down :-

Any helpful suggestions gratefully recieved.
Thanks Mike.
Mike Warren
Greenhorn

Joined: Oct 22, 2002
Posts: 4
Found that someone else had same problem in the Sun Forums :-
http://forum.java.sun.com/thread.jsp?forum=136&thread=303529
The answer is "You must add the too class-files (ConverterHome.class and Converter.class) to the web-archive and then deploy the ear-file again."
I've tried this - it fixes the errors in the Verifier, but I still can't get the web client to work - get the same errors in Internet Explorer as before.
Vaing compared the war files, in the ear files (example ear files are in the "j2eetutorial\examples\ears" directory)I note that the Sun example doesn't include these class files, so I don't think this can be the answer.
Any ideas anyone ?
The complete list of errors I get in IE are as follows :-


[ October 22, 2002: Message edited by: Mike Warren ]
[ October 22, 2002: Message edited by: Mike Warren ]
[ October 22, 2002: Message edited by: Mike Warren ]
Mikey Warren
Ranch Hand

Joined: Jun 15, 2001
Posts: 30
Just incase anyone else has had this problem I thought that I should note that I've got this working now - I got round it by using a different PC, so still not sure what the cause of problem is. I thinking its probably something simple - will add a note here if I find it out.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: J2EE Tutorial - Converter