wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes Connecting to ORB under J2EE RI Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Connecting to ORB under J2EE RI" Watch "Connecting to ORB under J2EE RI" New topic
Author

Connecting to ORB under J2EE RI

Valentin Treu
Greenhorn

Joined: Oct 23, 2002
Posts: 7
Hi there,
since 3 days i try to put a remote object in the
corba name service under the ri app server.
when i use the poa way i get the following error
tree when calling
:
org.omg.CORBA.INTERNAL: vmcid: SUN minor code: 209 completed: No
at com.sun.corba.ee.internal.iiop.GIOPImpl.createListener(GIOPImpl.java:256)
at com.sun.corba.ee.internal.iiop.GIOPImpl.getEndpoint(GIOPImpl.java:205)
at com.sun.corba.ee.internal.iiop.GIOPImpl.initEndpoints(GIOPImpl.java:133)
at com.sun.corba.ee.internal.POA.POAORB.getServerEndpoint(POAORB.java:492)
at com.sun.corba.ee.internal.POA.POAImpl.pre_initialize(POAImpl.java:156)
at com.sun.corba.ee.internal.POA.POAImpl.<init>(POAImpl.java:114)
at com.sun.corba.ee.internal.POA.POAORB.makeRootPOA(POAORB.java:114)
at com.sun.corba.ee.internal.POA.POAORB$1.evaluate(POAORB.java:132)
at com.sun.corba.ee.internal.core.Future.evaluate(Future.java:21)
at com.sun.corba.ee.internal.corba.ORB.resolveInitialReference(ORB.java:2488)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.java:2423)


when i use the older _xxxImplBase way i get the
error tree when calling :
org.omg.CORBA.OBJ_ADAPTER: vmcid: SUN minor code: 202 completed: No
at com.sun.corba.ee.internal.corba.ORB.connect(ORB.java:2053)
at com.inexsys.prototype.helper.ApplicationThread.<init>(ApplicationThread.java:35)
at com.inexsys.prototype.helper.J2EEManager.getDatabaseManager(J2EEManager.java:85)

i tried the following things:
- changed LISTEN_OPTIONS=-Dcom.sun.CORBA.connection.ORBListenSocket=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:2061 in setenv.bat
- changed name service port in orb.properties
what could this be ? is there missing something ?
i init my orb with:

thx so much for your help!!
valley
 
Don't get me started about those stupid light bulbs.
 
subject: Connecting to ORB under J2EE RI