wood burning stoves*
The moose likes EJB and other Java EE Technologies and the fly likes Problem with cmp at jboss 3.x Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Problem with cmp at jboss 3.x " Watch "Problem with cmp at jboss 3.x " New topic
Author

Problem with cmp at jboss 3.x

Sam Wang
Ranch Hand

Joined: Jul 17, 2001
Posts: 95
I deploy a entity bean on jboss sucessfully.
I can create a record through ejbcreate method and find this one through ejbfind method.
But I cann't see any record at database!
Help!!!


SCJP(2001)
Volodymyr Shram
Ranch Hand

Joined: Oct 17, 2002
Posts: 47
Originally posted by Stub Wang:
I deploy a entity bean on jboss sucessfully.
I can create a record through ejbcreate method and find this one through ejbfind method.
But I cann't see any record at database!
Help!!!

ok, please describe in details your problem. You can find your record via finder. So after that you may get any field of your "record". You said "But I cann't see any record at database!". What does that means? Describe in details please and we'll find the solving I think
Regards.
Sam Wang
Ranch Hand

Joined: Jul 17, 2001
Posts: 95
Ok.
[env]
jboss3.x + mysql
[problem]
I create a record by ejb create method.It's ok.
I get the record by ejb finder method.It's ok.
I execute select * from some-table through dba
tools,there is none record!!!
HanMing Low
Ranch Hand

Joined: Oct 18, 2001
Posts: 196
Hi,
I'm not exactly sure of the details.
But it is very likely that the record has gone into HyperSonic, JBoss's default database.
A quick check on the server.log should let you know which DataSource it uses.
If it use hsqldbDS, then, yup yup, it's the problem.
Otherwise, , then sorry I'm not sure.
Cheers.

Han Ming
Sam Wang
Ranch Hand

Joined: Jul 17, 2001
Posts: 95
Thanks!
 
Consider Paul's rocket mass heater.
 
subject: Problem with cmp at jboss 3.x