This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse + Weblogic Hot Deployment

 
Sonu Sharma
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello guys,
I am using Eclipse 2.1 for my development where I have multiple
projects. I have an ANT script to build and deploy the application to
Weblogic 7.0. The problem however is that when I do any changes to
JSPs, I need to re-build, deploy and restart Weblogic to see my
changes reflected....Restarting weblogic every time I change my JSPs
is becoming a pain as it takes about 3-4 minutes everytime...
Using WSAD was really easy as the Websphere Test Environment was
recompiling any modified JSPs while the WTE was up - no need of
restarting if I just change JSPs....
If anyone has faced a similar problem, please let me know how to go
about solving it....
Would switching to JBoss + Tomcat with Eclipse help me ?
Thanks,
Sonu
 
Lasse Koskela
author
Sheriff
Posts: 11962
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can't redeploy with WebLogic 7.0? Sounds weird...
Have you browsed the documentation?
 
John McDonald
Ranch Hand
Posts: 112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey Pal,
I am using Eclipse and weblogic. Lomboz is my pluggin. I have a big time when try to start the weblogic. I develop a simple bean. Below this bean I hooked it up with weblogic. That way I can kick off weblogic on Eclipse. But I have the following error:
<Unable to load performance pack, using Java I/O instead.
Please ensure that wlntio.dll is in: 'C:\Program Files\Java\j2re1.4.0_03bin;.;C:\WINNT\System32;C:\WINNT;D:\NetApps\ECF\util;C:\Oracle\Ora81\bin; java.lang.UnsatisfiedLinkError: no wlntio in java.library.path
java.lang.UnsatisfiedLinkError: no wlntio in java.library.path
What classpath do I need to set? Or how do I set the classpath? Thanks a bunch.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic