wood burning stoves 2.0*
The moose likes EJB and other Java EE Technologies and the fly likes Weblogic newbie question. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "Weblogic newbie question." Watch "Weblogic newbie question." New topic
Author

Weblogic newbie question.

Billy Fence
Greenhorn

Joined: Jul 17, 2003
Posts: 17
Hi,
Really hope someone out there can help me. I'm using standard weblogic 6.1 install with only one administration server 'myserver'. By default this is tied to machine (none), listens to 7001 and has an empty listen address. When I want to create a new logical server, for example one named applicserver I need to bind that to a machine. Since the machine listbox only shows me (none) I try that and start to run it. This is what happens:

<08-Aug-03 15:24:29 CEST> <Error> <NodeManager> <Could not start server 'wasp-adminserver' via Node Manager - reason: '[SecureCommandInvoker: Could not create a socket to the NodeManager running on host 'localhost:5555' to execute command 'online applicserver', reason: Connection refused: connect. Ensure that the NodeManager on host 'localhost' is configured to listen on port '5555' and that it is actively listening]'>

So I thought let's create a new machine and call that localhost that listens to another port, for example 7999. Then tried to bind the applicserver to that new machine and tried to start it. Again the above output. It drives me nutts. I don't have a helping hand close by and the weblogic documentation is too much to go through, so I'm stuck. Can anyone out there explain what I'm doing wrong.
Cheers
Billy
Lasse Koskela
author
Sheriff

Joined: Jan 23, 2002
Posts: 11962
    
    5
This question would have better chances of getting answered in the BEA/WebLogic Forum.
I assume you have already went through the documentation...?


Author of Test Driven (2007) and Effective Unit Testing (2013) [Blog] [HowToAskQuestionsOnJavaRanch]
Billy Fence
Greenhorn

Joined: Jul 17, 2003
Posts: 17
I will repost it in the bea/weblogic forum.
Kiitos
p.s. If we all would look at the documentation there would be no forum ;-)
I'm really stuck with this one.....
Anurag Mishra
Ranch Hand

Joined: Jun 16, 2003
Posts: 121
Hi Billy,
if u have created a new Domain using Configuration Wizard or something..
if u see ur Computer directory
c:/bea
there u might have creared some domain pls look for <B>"config.xml"</B> file
n then it will look like the below one
u need to specify ur machine name's IP address in <B>"ListenAddress"</B> and
Portno as 7000 in <B>"ListenPort"</B>
pls chk the belo mentioned file,
thanks
Anurag

<?xml version="1.0" encoding="UTF-8"?>
<Domain ConfigurationVersion="8.1.0.0" Name="anurag_domain">
<Server JMSThreadPoolSize="15" ListenAddress="182.89.140.83"
ListenPort="7001" Name="myserver" NativeIOEnabled="true"
ReliableDeliveryPolicy="RMDefaultPolicy" ServerVersion="8.1.1.0">
<SSL Enabled="false" HostnameVerificationIgnored="false"
IdentityAndTrustLocations="KeyStores" Name="myserver"/>
</Server>
<JMSFileStore Directory="rmfilestore" Name="FileStore"/>
<WSReliableDeliveryPolicy DefaultRetryCount="10"
DefaultTimeToLive="60000" Name="RMDefaultPolicy" Store="FileStore"/>
<Security Name="anurag_domain"
PasswordPolicy="wl_default_password_policy"
Realm="wl_default_realm" RealmSetup="true"/>
<EmbeddedLDAP
Credential="{3DES}w3eAHyL9m3x6psNFX5/UmEaloQjCavNJBo2xdbswhdI=" Name="anurag_domain"/>
<SecurityConfiguration
Credential="{3DES}eD9UAcvCYlqRvIxPCA7apQqP4w7PNviE5Lc5mkkJ4o5TdWncwWcHKHmNmCQpk3b7uAdafO9YS5BgpqZTjJofJJtdVSX5TAzx"
Name="anurag_domain" RealmBootStrapVersion="1"/>
<Realm FileRealm="wl_default_file_realm" Name="wl_default_realm"/>
<FileRealm Name="wl_default_file_realm"/>
<PasswordPolicy Name="wl_default_password_policy"/>
<JMSServer Name="WSStoreForwardInternalJMSServermyserver"
Store="FileStore" Targets="myserver">
<JMSQueue CreationTime="1059201907359"
JNDIName="jms.internal.queue.WSStoreForwardQueue"
JNDINameReplicated="false" Name="WSInternaljms.internal.queue.WSStoreForwardQueuemyserver"/>
<JMSQueue CreationTime="1059201907640"
JNDIName="jms.internal.queue.WSDupsEliminationHistoryQueue"
JNDINameReplicated="false" Name="WSInternaljms.internal.queue.WSDupsEliminationHistoryQueuemyserver"/>
</JMSServer>
<Application Name="_appsdir_Search_war"
Path="C:\bea\anurag_domain\applications"
StagedTargets="myserver" StagingMode="stage" TwoPhase="true">
<WebAppComponent Name="Search" Targets="myserver" URI="Search.war"/>
</Application>
</Domain>


SCJP 1.2
Billy Fence
Greenhorn

Joined: Jul 17, 2003
Posts: 17
Don't really get your explaination. Maybe I'm trying to say can you create more more than one nodemanager per physical machine. As far as I see it I'm trying to create a managed server on the same server as the administration server. When I try to start this managed server I invoke a nodemanager which is located on the administration server, and I wonder if that is possible?
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Weblogic newbie question.
 
Similar Threads
SecureCommandInvoker: Could not create a socket to the NodeManager in weblogic8.1
weblogic clustering for the multiple machines
NodeManager problem
Problem starting ManagedServer via Nodemanager
Weblogic newbie question.