Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

properties file....

 
Praveen Dharmavaram
Ranch Hand
Posts: 59
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
My Application is designed to read the JSP's from a properties file. The Servlet reads the properties file and forwards the response to the appropriate JSP to be rendered. This used to work fine in WebSphere 3.5. Now i migrated my application to WAS 5.0 and I ran the application in my WSAD 5.1. The request completes the trip but the JSP is not rendered. Any thoughts whats wrong with my Application.
Thanks
Praveen
 
Chris Mathews
Ranch Hand
Posts: 2712
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is not really enough to go on...
Is the Servlet reading the properties file correctly?
Is the Servlet forwarding to the correct page?
How is the Servlet forwarding to the JSP?
Is the JSP getting called? Does it compile successfully?
Throw in some print statements and/or fire up your debugger and see what is actually happening. Anything that I could say based on the information that you provided would merely be unfounded speculation.
 
Praveen Dharmavaram
Ranch Hand
Posts: 59
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I figured out the problem thanks to chris. I used the debugger to figure out that even though the JSP was being read out of the properties files, it wasnt in the correct path. So There wasnt anything to be displayed.
Thanks a lot for all your help.
Praveen
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic