File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes EJB and other Java EE Technologies and the fly likes weblogic-iiscluster problem !!!!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Reply locked New topic
Author

weblogic-iiscluster problem !!!!!!

Kiran Bandi
Greenhorn

Joined: Mar 04, 2003
Posts: 21
Friends ... here is my problem scenario. If any body has ideas, pl.share them.

I have Webservices exposed on weblogic server. UI (in .NET ) accesses the webservices API on WLS.(bunch of EJBs are deployed on the WLS)
Now I thought of converting the WLS to a clustered environment. So I created 2 manged servers (on the same machine ..just to try initially). I have assigned unique port numbers to them.I tried mutlcast test .looks like the intra-cluster communication is okay.
My problem is I dont want all the requests to be forwarded to weblogic. Static pages are still served by .NET part but i need this to look at the webservice on WLS (in a clustered environment) for the dynamic content.
In non clustered environment, i used to give the webservices url in the app settings of web.config as follows and it used to work great . <add key="xcservicelib.WSRef.XCWebService" value="http://localhost:7001/CCWebModule/services/XCWebServiceSoap"/>
Now I have two managed servers in the cluster at 8001 and 9001 ports on th e same machine.
I followed the steps to configure iis-plugin(copied the dlls to a dir c:\plug-ins) and created ini file and included the following.
WebLogicCluster=localhost:8001,localhost:9001 ConnectTimeoutSecs=20 ConnectRetrySecs=2 Debug=ON WlForwardPath=/CCWebModule/services/XCWebServiceSoap WLLogFile=c:\plug-ins\log\iisproxy.log
I tried to access using the cluster address.It does not work (UI does not find the underlying server!) Could somebody help me to properly forward request (only webservice calls !)
Thanks for your help .


If you want to do it...DO IT!!<br />You can't cross a sea by staring at it!
Chris Mathews
Ranch Hand

Joined: Jul 18, 2001
Posts: 2712
Closing this thread. Please post any replies here.
In the future please avoid posting the same question to multiple forums.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: weblogic-iiscluster problem !!!!!!
 
Similar Threads
log4J in clustered environment
please answer this 128 questions for WLS. Urgently!
How to access Weblogic cluster
Clustering problem... any ideas ?!
Problem while accessing the server with the apache using https port