• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem running EJB client

 
Manoj Gundawar
Ranch Hand
Posts: 169
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am trying to run EJB client from dos prompt. (not using any WSAD stuff) I am pointing all required jars in classpath(I hope I am). Also pointing to IBM java (as EJB was created in WSAD)
I am getting following error:
----------------------
Exception in thread "P=926057 =0:CT" java.lang.NoClassDefFoundError: org/omg/CosPropertyService/PropertyNotFound
--------------------
I did search on google but did not find anything on this error.
I have following jars in my classpath:
set classpath=%classpath%;.;./lib/activation.jar;./lib/ejbcontainer.jar;./lib/ibmorb.jar;./lib/ivjejb35.jar;./lib/j2ee.jar;./lib/naming.jar;./lib/namingclient.jar;./lib/utils.jar;./lib/runtime.jar;./lib/webcontainer.jar;./lib/websphere.jar;./lib/iwsorb.jar;./lib/rt.jar

Any help would be greatly appriciated.

(Please dont move this to WSAD, as this is strictly an EJB issue )

Thanks
Manoj
 
Layi Egbeyemi
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Jmannu,

I don't see ....../servlet-api.jar!!!
 
Manoj Gundawar
Ranch Hand
Posts: 169
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Isn't J2ee.jar enough?
 
Layi Egbeyemi
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No it isn't...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic